Autocomplete creates non-mailable addresses

VERIFIED DUPLICATE of bug 93453

Status

Thunderbird
Message Compose Window
--
major
VERIFIED DUPLICATE of bug 93453
13 years ago
13 years ago

People

(Reporter: Ethan Benatan, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.6) Gecko/20050223 Firefox/1.0.1
Build Identifier: version 1.0 (20041206)

Autocomplete currently appends a generic ending like "@mydomain.foo" onto the
end of any unmatched string typed into the compose "To" field.  This is very
confusing to users who are expecting autocomplete to expand when it finds a
match, and who have a hard time telling the difference between a correct lookup
match and a "dumb" autocomplete that indicates no match has been found. 

One good take on a much better behavior is in the autocomplete spec at
http://www.mozilla.org/mailnews/specs/autocomplete/ .  This doc suggests that
"no match" conditions should be expanded as they are now, but in red and with a
"no match found" warning right in line with the expansion (NOT a pop-up).  There
are other acceptable behaviors like putting this under prefs control to turn it
off or set the autocompletion (which currently just sucks the domain from the
user's email address). The underlying code is currently completely inflexible.

Reproducible: Always

Steps to Reproduce:
1. Compose a message
2. Type into the To field a string that does not match your directory or address
book, like "mtchell baker"
3. Watch it get turned into an apparently expaned, but completely useless
address, like "mtchell baker@mozilla.org".

Actual Results:  
An unroutable address that **looks like it was the result of a correct
expansion**  was placed in the To field, where the user is expecting a routable
address.

Expected Results:  
The user should be warned that Tbird is making a wild guess, OR Tbird should not
try to guess at all.

I consider this a major bug because it is a common report from our 1,000 users
that they are routinely confused by this, and want to stop using Tbird; but it's
easy to fix.

Comment 1

13 years ago
this is a duplicate of bug 93453

Comment 2

13 years ago
Yes it is.

*** This bug has been marked as a duplicate of 93453 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.