If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

When xpinstall.enabled == false, "Edit Options" button in toolbar message brings up empty window

VERIFIED DUPLICATE of bug 284081

Status

()

Firefox
Preferences
--
minor
VERIFIED DUPLICATE of bug 284081
13 years ago
8 years ago

People

(Reporter: Daniel Cater, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2) Gecko/20050321 Firefox/1.0+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2) Gecko/20050321 Firefox/1.0+

When xpinstall is disabled (xpinstall.enabled == false) following a link to an
XPI package displays a toolbar at the top of the tab. It states that software
cannot currently be installed. There is then an "Edit Options" button so that
this can be changed. However, clicking the button brings up a very small window
with the title "Firefox" and there are no options present.

Reproducible: Always

Steps to Reproduce:
(With xpinstall.enabled == false,)

1. Follow the URL in this bug.
2. Click the button that appears in the toolbar.
Actual Results:  
Small, empty window appeared.

Expected Results:  
Preferences window should have appeared where the xpinstall preference could be
changed.

I am assuming this is a regression due to new preferences.
This is firefox UI.
Assignee: xpi-engine → bugs
Component: Installer: XPInstall Engine → Preferences
Product: Core → Firefox
QA Contact: mconnor

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 284081 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.