Chatzilla wouldn't accept <ENTER>

VERIFIED FIXED

Status

P3
normal
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: Sebastian, Assigned: rginda)

Tracking

Trunk
x86
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Using build 2/21

When choosing Tasks->IRC Chat the Chatzilla window opens. You can type e.g.
/help or /attach moznet but when you hit <ENTER> nothing special happens.
The cursor is still there and I can edit the same line.
The (blue textured) output area has no text on it at all.

EXPECTED BEHAVIOUR: It should open a connection to Mozilla, show the help
message or whatever was chosen.
(Assignee)

Comment 1

19 years ago
Do you see any javascript errors on the console?  The unresponsiveness usually
happens after the initilization code bombs.

Comment 2

19 years ago
I used a debuug build of Mozilla.  I marked/pasted here from the console window.



WARNING: not supported for views, file G:\mozilla_source\mozilla\view\src\nsScro

llPortView.cpp, line 91

WARNING: not supported for views, file G:\mozilla_source\mozilla\view\src\nsScro

llPortView.cpp, line 91

JavaScript Error: TypeError: client.output has no properties

URL: chrome://chatzilla/content/static.js

LineNo: 501



Lost focus.

WEBSHELL+ = 12

Lost focus.

JavaScript Error: TypeError: obj has no properties

URL: chrome://chatzilla/content/static.js

LineNo: 250


(Reporter)

Comment 3

19 years ago
Here is the important parts of the console output. It's not JavaScript in 
general that has "bombed" but JS is missing some properties...

WEBSHELL+ = 4
*** Timing layout processes on url: 'chrome://chatzilla/content/', webshell: 
0075CC78
[...]
Total (Layout + Page Load) Time (webshell=0075CC78): Real time 0:0:1.870, CP 
time 1.870
JavaScript Error: TypeError: client.output has no properties
URL: chrome://chatzilla/content/static.js
LineNo: 501
[...]
Tokenize Time: Real time 0:0:0.0, CP time 0.000
JavaScript Error: TypeError: obj has no properties
URL: chrome://chatzilla/content/static.js
LineNo: 250

Parse Time (this=0163FDC8): Real time 0:0:0.0, CP time 0.000
Tokenize Time: Real time 0:0:0.0, CP time 0.000
[...]
Tokenize Time: Real time 0:0:0.0, CP time 0.000
JavaScript Error: TypeError: obj has no properties
URL: chrome://chatzilla/content/static.js
LineNo: 250
(Reporter)

Comment 4

19 years ago
Oops, didn't see that somebody already posted the console output. So it's the 
same cause, but anyway I am not getting this error

WARNING: not supported for views, file G:\mozilla_source\mozilla\view\src\nsScro
llPortView.cpp, line 91
.
Sebastian@SSpaeth.de - are you still seeing this problem on recent builds? This 
bug was last touched a month and a half ago...

Gerv
(Reporter)

Comment 6

19 years ago
As I don't build Mozilaa myself and Chatzilla is turned off since M14 in the 
nightlies, I had no chance to have another look at it. I will check as soon as 
Chatzilla is back.
Chatzilla is back...

Gerv
(Reporter)

Comment 8

19 years ago
And works perfectly! Thanks Robert Ginda, it's really cute...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 9

19 years ago
verified
Product: Core → Other Applications
You need to log in before you can comment on or make changes to this bug.