special chars in selection (æøåé) gets mungled (??a*e')

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
13 years ago
10 years ago

People

(Reporter: Morten Nilsen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b) Gecko/20050217 Mnenhy/0.7.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b) Gecko/20050217 Mnenhy/0.7.1

Selecting text with special characters in mozilla and pasting them into other
apps (eterm, xterm, gaim) messes them up 

Reproducible: Always

Steps to Reproduce:
1. select the text "æøåé" in mozilla
2. go to another app
3. press mouse3

Actual Results:  
æøåé becomes ??a*e'

Expected Results:  
æøåé should appear

running e16 and eterm from cvs, mozilla from official binary tarball on Trustix
Secure Linux. xorg-x11, gaim and other progs from TSL contrib

Comment 1

13 years ago
Although I'm on Windows, I doubt if this is a Mozilla bug.

Updated

13 years ago
Version: unspecified → Trunk
We just put the data on the clipboard as UTF-16 or UTF-8, last I checked...
sounds like these apps are screwing up encoding conversion into whatever
encoding they're using.
This may be a dupe or dependency of bug 44496, or bug 159535, or bug 128480, or
bug 104027.

Comment 4

13 years ago
Where UTF8_STRING is supported (which means virtually all Linux, *BSD), we use
UTF8_STRING so that all the applications that understand that selection type
should have no problem. Not all applications (even on Linux) understand
UTF8_STRING. Some old applications don't so that COMPOUND_TEXT (bug 159535 as
pointed out by Simon) needs to be used for them. . However, it's strange that
gaim and xterm caused a problem for you. (they're modern enough to support
UTF8_STRING)  I can't reproduce the problem with them. 
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.2pre) Gecko/2008071201 SeaMonkey/2.0a1pre

WFM. Ican paste the æøåé from this bug's Summary into both gvim and konsole; however both are running in a UTF-8 locale.

If you want to REOPEN, please check first that the destination application is using a charset which can represent the characters to be pasted (for instance, trying to paste Œœ into a Latin1 aka ISO-8859-1 terminal won't work); and mention which _recent_ version of SeaMonkey (or Firefox or...) you are using, in which application you are trying to paste, and which charset (or 'encoding') the latter is set to display.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.