importfromxml.pl does not process attachments; move does not move attachments

RESOLVED DUPLICATE of bug 233984

Status

()

Bugzilla
Bug Import/Export & Moving
RESOLVED DUPLICATE of bug 233984
13 years ago
13 years ago

People

(Reporter: William Milbratz, Assigned: justdave)

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050304 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050304 Firefox/1.0.1

I found some issue trying to move bugs and run importfromxml.pl

The issues are:
-attachments aren't processed. The DTD has an 'attachment' element, and
'move' generates some entries,  but the importxml.pl doesn't know how to
handle it. 
   Unknown bug field "attachment" encountered while moving bug

-along these lines, move.pl doesn't export the attachment data. I had
hoped that it would include the attachment as mime-encoded data.  It only dumped
the file name.

-importfromxml.pl also didn't process a few fields generated by 'move.pl'

  Unknown bug field "reporter_accessible" encountered while moving bug
  Unknown bug field "cclist_accessible" encountered while moving bug



Reproducible: Always

Steps to Reproduce:
1. move a bug with attachments
2. run importfromxml.pl


Actual Results:  
error messages above

Expected Results:  
1) Exported the attachment info as Mime-encoded information
2) Importfromxml.pl should process the attachment.

*** This bug has been marked as a duplicate of 233984 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.