Lack of components in Advanced Search leads to error when clicking Components

VERIFIED DUPLICATE of bug 285090

Status

()

Bugzilla
Bugzilla-General
VERIFIED DUPLICATE of bug 285090
13 years ago
12 years ago

People

(Reporter: nick_abbo, Unassigned)

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Build Identifier: bugzilla-2.18

I have a fresh installation of bugzilla with no projects or components setup. 
When I go to Advanced Search and click components I get the resulting error. I 
think bugzilla should return a 0 components page, or is thier some error 
elsewhere?


DBD::mysql::st execute failed: You have an error in your SQL syntax 
near 'ORDER BY name' at line 1 [for Statement "SELECT name, initialowner, 
initialqacontact, description FROM components WHERE product_id =  ORDER BY 
name"] at Bugzilla/DB.pm line 62
	Bugzilla::DB::SendSQL('SELECT name, initialowner, initialqacontact, 
description FROM...') called 
at /apache_server/public_html/bugzilla/describecomponents.cgi line 88


Reproducible: Always

Steps to Reproduce:
1. click search existing bugs on front page
2. click advanced search
3. click components 

Actual Results:  
DBD::mysql::st execute failed: You have an error in your SQL syntax 
near 'ORDER BY name' at line 1 [for Statement "SELECT name, initialowner, 
initialqacontact, description FROM components WHERE product_id =  ORDER BY 
name"] at Bugzilla/DB.pm line 62
	Bugzilla::DB::SendSQL('SELECT name, initialowner, initialqacontact, 
description FROM...') called 
at /apache_server/public_html/bugzilla/describecomponents.cgi line 88


Expected Results:  
I think it should have told me you have no components.

Comment 1

13 years ago
This has been fixed two weeks ago.

*** This bug has been marked as a duplicate of 285090 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

12 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.