Make XLink work or ignore it

RESOLVED DUPLICATE of bug 334587

Status

()

RESOLVED DUPLICATE of bug 334587
14 years ago
12 years ago

People

(Reporter: annevk, Unassigned)

Tracking

({testcase})

Trunk
testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

14 years ago
Currently you can apply an XLink to SVG elements and it will look like an actual
link (underlined, a different cursor), but you can click on it and go to the
destination.

We should either make this work or ignore XLink attributes on other SVG elements
than A (and other elements in the SVG namespace where XLink attributes are allowed).
(Reporter)

Comment 1

14 years ago
Created attachment 178261 [details]
testcase - svg:text
(Reporter)

Comment 2

14 years ago
Created attachment 178262 [details]
testcase - svg:rect
(Reporter)

Comment 3

14 years ago
Created attachment 178263 [details]
testcase - svg:circle
Is there a "not" missing somewhere in comment 0?

Probably more or less a dup of bug 211916
Depends on: 211916
(Reporter)

Comment 5

14 years ago
There is, "you *not* click on it and go to ..."

But then for SVG, right? Or will fixing that bug fix it for all namespaces we
tend to support?
(Reporter)

Updated

14 years ago
Blocks: 61664
It would be nice if the SVG WG would explain how on earth XLink is actually suppose to work with SVG. I certainly don't understand it.
Looks like we ignore xlink attributes now. Presumably fixed by bug 334587.

Close as WORKSFORME?
Ah, yeah, I forgot about this bug. And yes, in bug 334587 we took the "ignore it" route.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 334587
You need to log in before you can comment on or make changes to this bug.