Closed Bug 287264 Opened 15 years ago Closed 15 years ago

Provide a way to view XML-based document as generic XML

Categories

(Core :: XML, enhancement)

enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 155730

People

(Reporter: minghong, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

For XML-based documents like application/xhtml+xml, it would be nice to have way
to view it as generic XML document, perhap like the stylesheet switcher (which
is removed anyway).

For XML-based documents that Mozilla doesn't support, like image/svg,
application/anythinghere+xml (RSS, Atom, OPML, OML, etc), there should be an
option to open them as generic XML. Currently they can only be downloaded or
opened as default application like Adobe SVG Viewer.

Reproducible: Always

Steps to Reproduce:
1. Open a XML-based document

Actual Results:  
Either render correctly or don't render at all.

Expected Results:  
For supported types, should render correct and provide a "XML switcher".
For unsupported types, should provide way to view as generic XML.
We have a bug for that.

*** This bug has been marked as a duplicate of 155730 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.