incorrect What's Related content due to client

VERIFIED WORKSFORME

Status

SeaMonkey
Sidebar
P2
normal
VERIFIED WORKSFORME
18 years ago
13 years ago

People

(Reporter: johng, Assigned: Samir Gehani)

Tracking

Trunk
mozilla0.9.9
x86
Other
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: no additional work over bug 27048)

(Reporter)

Description

18 years ago
Somehow What's Related is grabbing different content in 4.x then it does in mozilla.

Similiar to bug 28714, same steps to reproduce:

* go to bugzilla.mozilla.org.
* view What's Related in My Sidebar
* click on "Linux.org" link within What's Related. You are now viewing linux.org.

Now compare the data you get in What's Related in mozilla with what you get with
Navigator 4.x. Although some of the data is the same (Netscape search
categories, "search on XXX"), the Alexa links (the bottom half plus stock quotes
and news stories) are incorrect matching netscape.com as the domain instead of
linux.org. ALL the What's Related data should match linux.org, none of it
should match the redirect domain info.netscape.com.

Note that 4.x works perfectly - mozilla is doing something funky.
(Reporter)

Comment 1

18 years ago
Nominating for beta1 because a key feature does not work.  Default sidebar panel 
What's Related does not work.  Marking M14
Keywords: beta1
Target Milestone: M14

Updated

18 years ago
Whiteboard: [PDT+]

Comment 2

18 years ago
This is a duplicate of 20072. I will leave this one open since it is a different 
manifestation of that bug.
Depends on: 20072
Whiteboard: [PDT+] → [PDT+] blocked by 20072

Updated

18 years ago
Whiteboard: [PDT+] blocked by 20072 → [PDT+] no additional work over bug 20072

Comment 3

18 years ago
Now that 20072 is fixed, please mark this bug as fixed to get it off our beta
stopper radar! ;-)

ALternatively, indicate on the status whiteboard what the problem is, and what
the landing date should be.
Thanks,
Jim

Comment 4

18 years ago
20072 was not fixed. It was only marked duplicate of 27048.
Depends on: 27048
Whiteboard: [PDT+] no additional work over bug 20072 → [PDT+] no additional work over bug 27048

Comment 5

18 years ago
27048 is PDT-, so this should not be PDT+. This is fairly minor for beta.

Removing beta1 keyword and PDT+ status.
Keywords: beta1
Whiteboard: [PDT+] no additional work over bug 27048 → no additional work over bug 27048

Comment 6

18 years ago
Move to M16 ...
Target Milestone: M14 → M16

Comment 7

18 years ago
spam: changing qa contact on sidebar bugs from paulmac to shrir@netscape.com 
(all 67 of them!)
QA Contact: paulmac → shrir

Updated

18 years ago
Target Milestone: M16 → M18

Comment 8

18 years ago
Move to M21 target milestone.
Target Milestone: M18 → M21

Comment 9

17 years ago
slamm gone, ->matt
Assignee: slamm → matt

Comment 10

17 years ago
spam : changing qa to sujay (New Sidebar QA)
QA Contact: shrir → sujay
(Assignee)

Comment 11

17 years ago
Taking.
Assignee: matt → sgehani
(Assignee)

Comment 12

17 years ago
Closing for Sujay to verify.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 13

17 years ago
I still see different data when comparing to 4.x...

reopening for investigation..
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Assignee)

Updated

17 years ago
Status: REOPENED → ASSIGNED
Priority: P3 → P2
Target Milestone: --- → mozilla0.9.6

Comment 14

16 years ago
This is partly a server issue partly a client issue.
Looks like if you go to http://www.mozilla.org
The related sites are not showing up.  This is probably a template problem 
maybe due to when we put it back in 6.1.   I would first look at syntax changes 
between 6.0 and 6.1 .

http://www-rl.netscape.com/wtgn?www.netscape.com

I had a bug on this a while ago an noticed it was a server issue.  Sometimes 
the server servers different content to different versions of the browser.
(Assignee)

Updated

16 years ago
Target Milestone: mozilla0.9.6 → mozilla0.9.7
(Assignee)

Comment 15

16 years ago
Moving to mozilla0.9.8.
Target Milestone: mozilla0.9.7 → mozilla0.9.8
(Assignee)

Updated

16 years ago
Target Milestone: mozilla0.9.8 → mozilla0.9.9
(Assignee)

Comment 16

16 years ago
What's Related content is now entirely web-based (Served by Alexa).
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → WORKSFORME

Comment 17

16 years ago
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.