Composer crashed while loading a website via Open Web Location [@ nsQueryInterface::operator() ]

RESOLVED WORKSFORME

Status

SeaMonkey
Composer
--
critical
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: Zook Valem, Unassigned)

Tracking

(Depends on: 1 bug, 4 keywords)

Trunk
x86
Windows 2000
crash, pp, regression, testcase

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050321
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050321

Composer crashed while loading a website,
"http://www.urbancinefile.com.au/home/boxoffice.asp" via the File --> Open Web
Location and with selection of "Open into Composer Window" selected.  Then
talkback was activated but unable to send the data (got stuck) for unknown reason.

Reproducible: Sometimes

Steps to Reproduce:
1. Open Composer
2. File --> Open Web Location
3. Enter http://www.urbancinefile.com.au/home/boxoffice.asp into the textbox
4. On that same dialog window, select the option to open into the composer
window (not navigator window).
Actual Results:  
Sometime crashed and talkback agent was unable to send the data for unknown reason.

Expected Results:  
Not crash.

Popup Dialog Window occurred and mentioned about the memory pointer issues. 
(See Snapshot)
(Reporter)

Updated

13 years ago
Depends on: 282782
(Reporter)

Comment 1

13 years ago
Created attachment 178314 [details]
Snapshot of Memory Error and Talkback activated...
(Reporter)

Comment 2

13 years ago
Can anyone tell me how to get the talkback from the my local machine and send it
manually??  Or posting some information from the talkback itself.  Thanks...
(Reporter)

Updated

13 years ago
Version: unspecified → Trunk

Comment 3

13 years ago
zip %appdata%\Talkback\MozillaOrg and attach it here.
(Reporter)

Comment 4

13 years ago
Created attachment 178324 [details]
3 talkbacks related to this same bug....

Thanks for the instruction and attached.

Comment 5

13 years ago
Comment on attachment 178324 [details]
3 talkbacks related to this same bug....

TB4535314G, TB4532639M
Attachment #178324 - Attachment is obsolete: true

Updated

13 years ago
Keywords: crash

Comment 6

13 years ago
Incident ID: 4540590
Stack Signature	nsQueryInterface::operator() be516cca
Product ID	MozillaTrunk
Build ID	2005032105
Trigger Time	2005-03-23 01:05:59.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	xpcom_core.dll + (0000103b)
URL visited	-
User Comments	
Since Last Crash	68 sec
Total Uptime	44543 sec
Trigger Reason	Access violation
Source File, Line No.
c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpcom/build/nsCOMPtr.cpp,
line 47
Stack Trace 	
nsQueryInterface::operator() 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpcom/build/nsCOMPtr.cpp,
line 47]
nsCutCommand::IsCommandEnabled 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/editor/libeditor/base/nsEditorCommands.cpp,
line 212]
nsControllerCommandTable::IsCommandEnabled 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/embedding/components/commandhandler/src/nsControllerCommandTable.cpp,
line 138]
nsBaseCommandController::IsCommandEnabled 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/embedding/components/commandhandler/src/nsBaseCommandController.cpp,
line 117]
XPTC_InvokeByIndex 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp,
line 102]
XPCWrappedNative::CallMethod 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp,
line 2065]
XPC_WN_CallMethod 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 1287]
js_Invoke 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/js/src/jsinterp.c,
line 1293]
js_Interpret 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/js/src/jsinterp.c,
line 3568]
js_Invoke 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/js/src/jsinterp.c,
line 1313]
js_InternalInvoke 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/js/src/jsinterp.c,
line 1390]
JS_CallFunctionValue 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/js/src/jsapi.c, line
3804]
nsJSContext::CallEventHandler 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/dom/src/base/nsJSEnvironment.cpp,
line 1384]
nsJSEventListener::HandleEvent 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/dom/src/events/nsJSEventListener.cpp,
line 184]
nsEventListenerManager::HandleEventSubType 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/content/events/src/nsEventListenerManager.cpp,
line 1545]
nsEventListenerManager::HandleEvent 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/content/events/src/nsEventListenerManager.cpp,
line 1642]
nsXULElement::HandleDOMEvent 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/content/xul/content/src/nsXULElement.cpp,
line 2046]
nsXULCommandDispatcher::UpdateCommands 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/content/xul/document/src/nsXULCommandDispatcher.cpp,
line 384]
nsGlobalWindow::UpdateCommands 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/dom/src/base/nsGlobalWindow.cpp,
line 3711]
nsDocViewerSelectionListener::NotifySelectionChanged 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/base/nsDocumentViewer.cpp,
line 3027]
nsTypedSelection::NotifySelectionListeners 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/generic/nsSelection.cpp,
line 7278]
nsSelection::NotifySelectionListeners 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/generic/nsSelection.cpp,
line 3004]
nsHTMLEditor::BeginningOfDocument 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/editor/libeditor/html/nsHTMLEditor.cpp,
line 553]
nsEditor::Init 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/editor/libeditor/base/nsEditor.cpp,
line 318]
nsPlaintextEditor::Init 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/editor/libeditor/text/nsPlaintextEditor.cpp,
line 161]
nsHTMLEditor::Init 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/editor/libeditor/html/nsHTMLEditor.cpp,
line 254]
nsEditingSession::SetupEditorOnWindow 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/editor/composer/src/nsEditingSession.cpp,
line 452]
nsEditingSession::EndDocumentLoad 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/editor/composer/src/nsEditingSession.cpp,
line 1079]
nsEditingSession::OnStateChange 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/editor/composer/src/nsEditingSession.cpp,
line 784]
nsDocLoader::FireOnStateChange 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/uriloader/base/nsDocLoader.cpp,
line 1194]
nsDocLoader::doStopDocumentLoad 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/uriloader/base/nsDocLoader.cpp,
line 832]
nsDocLoader::OnStopRequest 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/uriloader/base/nsDocLoader.cpp,
line 653]
nsLoadGroup::RemoveRequest 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/netwerk/base/src/nsLoadGroup.cpp,
line 732]
HandleImagePLEvent 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/content/base/src/nsImageLoadingContent.cpp,
line 639]
PL_HandleEvent 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpcom/threads/plevent.c,
line 699]
0x778b0c24
Summary: Composer crashed while loading a website via Open Web Location → Composer crashed while loading a website via Open Web Location [@ nsQueryInterface::operator() ]

Comment 7

13 years ago
Repro doesn't crash with Suite 1.7.6/WXP.
Keywords: regression
(Reporter)

Comment 8

13 years ago
Created attachment 179542 [details]
Testcase #1

Created Testcase #1 that can produceda Composer crash...
(Reporter)

Comment 9

13 years ago
Will try to simplify the testcase further when I have time.  It become trickier
to narrow it down further.

Make sure to kill any existing instance of Mozilla before using hte testcase as
I found that the previous Composer crash doesn't close the Mozilla instance.  It
prevent testcase #1 from producing the Composer crash...

I noticed that if I remove any of the existing anchor tag then the testcase #1
start working okay.  But I wouldn't count on it because if I remove any other
non-anchor tags then testcase #1 start working okay as well.

(Reporter)

Updated

13 years ago
Keywords: testcase

Updated

12 years ago
Attachment #179542 - Attachment mime type: text/plain → text/html

Comment 10

12 years ago
wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.9a1) Gecko/20060328 SeaMonkey/1.5a

testing Testcase #1 Attachment id=179542 it opened as a composer window, with the tabs <Normal> <Tabs> <Source> <Preview> at the bottom, but these vanished when loading was done. I then changed the MIME Type of Attachment id=179542 from text/plain to text/html and got the normal composer page.

Is this bug, URL and testcase, still crashing somewhere, now a year after it was filed?
(Reporter)

Comment 11

12 years ago
I'll have to test that in a couple weeks from now.  
(Reporter)

Comment 12

12 years ago
Yep, still crash with Seamonkey Build ID #2005120508 from the latest nightly build last week.  Look like it's a Win2000 bugs only..

How come the attachment is changed from text/plain to text/html?  I left it as text/plain so I can read the texts and and build a simplier testcase but I haven't that part to work yet.  Then I haven't spend some time on it.

Comment 13

12 years ago
people can download the testcase by selecting save as from a context menu or similar. making the testcase text/html enables us to use it as a testcase which is what we normally want to do.
WFM, Seamonkey trunk Linux (debug build)
Keywords: pp
(In reply to comment #12)
> Yep, still crash with Seamonkey Build ID #2005120508 from the latest nightly
> build last week.  Look like it's a Win2000 bugs only..

That Build ID looks a bit old, could you try the latest trunk build please?
http://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/latest-trunk/
(Reporter)

Comment 16

12 years ago
That build id # was wrong.  Not sure why it said 2005-12-xxxxxx  Should have said something like 2006-04-xxxxx  (the week around of that posting's date).  Maybe I downloaded the wrong one from the ftp site...

Anyway, it seem to work now.  The only different between now and April is that I got a Comcast Internet Broadband 2 weeks ago.  The old one was with the GetNetscape via modem which I use for 2 years.  It's possible that the Composer had choked while waiting for the downloading via the modem while rendering.   (Or could be someone fixed a un-related things that fixed this bug).

Seem that I have no further use of this bug since it now work.  I also don't think anybody else would be working on this bug as well....  I still have yet to buy a firewall/router in order to get the multiple computers working on the same Internet before I can start investing my time on bug squashing, debugger and bug fixing...  So, marking it as WFM...
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
Crash Signature: [@ nsQueryInterface::operator() ]
You need to log in before you can comment on or make changes to this bug.