mail compose autosave should imply save without asking on compose window close

RESOLVED DUPLICATE of bug 307046

Status

--
minor
RESOLVED DUPLICATE of bug 307046
14 years ago
11 years ago

People

(Reporter: tuukka.tolvanen, Assigned: mscott)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2) Gecko/20050319 Firefox/1.0+
Build Identifier: version 1.0+ (20050313)

When the mail compose autosave pref is set, a redundant confirmation dialog pops
up when closing the mail compose window, unless the current message version has
been saved (explicitly or automatically) as a draft. By way of parody, the
appropriate wording for the dialog should be: "The message you have been typing
has been saved automatically every n minutes so you don't lose any changes to
it. Would you like to lose the changes from the last n-m minutes?" :)

The mail compose autosave pref should imply save without asking on compose
window close. The choice given in the dialog is not useful, since it is between
 a) "Save": Leave the currently visible version of the message in Drafts.
 b) "Don't Save": Leave an unknown version (the user has no idea when exactly
    the autosave happened) of the message in Drafts.
 c) "Cancel": Continue editing.

Choice (a) makes sense, (b) is useless, (c) is obviated by (a) since re-opening
the draft provides undo for the compose window close action.

Reproducible: Always

Steps to Reproduce:
1. In options / composition, set the Auto Save every n minutes pref.
2. Compose new message, type some words in.
3. Close mail compose window.

Actual Results:  
"Save Message" dialog asking if message should be saved to Drafts.

Expected Results:  
Should save message to Drafts without asking.

Updated

14 years ago
Version: unspecified → Trunk

Comment 1

13 years ago
This bug exists because auto-save implementation is flawed - in the ideal case
the "Dont save" option is useful - we expect when this is clicked the auto-saved
draft should be deleted.

See this thread for more on this -
http://forums.mozillazine.org/viewtopic.php?t=313069

(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2)
Gecko/20050319 Firefox/1.0+
> Build Identifier: version 1.0+ (20050313)
> 
> When the mail compose autosave pref is set, a redundant confirmation dialog pops
> up when closing the mail compose window, unless the current message version has
> been saved (explicitly or automatically) as a draft. By way of parody, the
> appropriate wording for the dialog should be: "The message you have been typing
> has been saved automatically every n minutes so you don't lose any changes to
> it. Would you like to lose the changes from the last n-m minutes?" :)
> 
> The mail compose autosave pref should imply save without asking on compose
> window close. The choice given in the dialog is not useful, since it is between
>  a) "Save": Leave the currently visible version of the message in Drafts.
>  b) "Don't Save": Leave an unknown version (the user has no idea when exactly
>     the autosave happened) of the message in Drafts.
>  c) "Cancel": Continue editing.
> 
> Choice (a) makes sense, (b) is useless, (c) is obviated by (a) since re-opening
> the draft provides undo for the compose window close action.
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1. In options / composition, set the Auto Save every n minutes pref.
> 2. Compose new message, type some words in.
> 3. Close mail compose window.
> 
> Actual Results:  
> "Save Message" dialog asking if message should be saved to Drafts.
> 
> Expected Results:  
> Should save message to Drafts without asking.

(Reporter)

Comment 2

13 years ago
Please quote as little as possible, and only if it's necessary in order to see
what you're referring to. Usually, as in the case of comment 1 here, not at all.

> the "Dont save" option is useful - we expect when this is clicked the auto-saved
> draft should be deleted.

That doesn't appear to be the way the feature is designed atm, and as such is
irrelevant here; if you think it should work that way, file an rfe with
rationale. The other points at
http://forums.mozillazine.org/viewtopic.php?t=313069 are also orthogonal to this
bug.

Comment 3

13 years ago
(In reply to comment #2)

I am sorry for the indiscriminating quoting, but I clicked on reply and it came
by default - should have removed it before posting. 

Anyway, the original post claimed the dialog is redundant. My point was to say
it is not, from a final intent (it may be redundant in the current
implementation, but that implementation should change). I could perfectly well
prefer to auto-save my messages so I dont lose them due to crashes, but I dont
want to save a message that I deliberately cancel and choose dont-save. Just
because I auto-saved it does not mean I need to delete it from drafts manually
everytime composition is cancelled - this would also be consistent with current
behaviour where dont-save option does not leave anything in Drafts.

So this bug actually depends on the other bug being fixed or not -
http://forums.mozillazine.org/viewtopic.php?t=313069

Or am I missing something here?
QA Contact: message-compose

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 307046
You need to log in before you can comment on or make changes to this bug.