"show article summary" setting not respected

RESOLVED DUPLICATE of bug 259018

Status

RESOLVED DUPLICATE of bug 259018
14 years ago
10 years ago

People

(Reporter: rene, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050306 Firefox/1.0.1 (Debian package 1.0.1-2)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050306 Firefox/1.0.1 (Debian package 1.0.1-2)

I have a bunch of rss feeds in an rss news & blogs account.
The account have the "show article summary" option set from the beginning
Feeds added have the option set too when they are added.
Still some feeds show the web-pages anyway.

Some feeds that happen to do it now (though it is not consistent)

http://www.washingtonmonthly.com/index.rdf
http://news.bbc.co.uk/rss/newsonline_world_edition/front_page/rss.xml


Reproducible: Sometimes

Steps to Reproduce:
1. create an rss account
2. tick the "show article summary" option
3. add some feeds
4. watch the summaries from the feed, no web pages
Actual Results:  
For some feeds, the web-pages are shown anyway.

Expected Results:  
Summaries from the feed should be displayed.
Should work too when offline.

Comment 1

14 years ago
I have had similiar problems with 1.0, but I couldn't narrow them down.

maybe duplicate Bug 259018 ??
(Reporter)

Comment 2

14 years ago
I have figured out a little bit more.

I have the "show article summary" set.
I add a new feed to the account and the feed is loaded.
These articles show as summaries, not as web pages.
Later articles from the feed, ie those not loaded initially, show as web pages,
even though the "show article summary" has not been changed.

So the setting is respected on the initial load, but not later.
(Reporter)

Comment 3

14 years ago
It seems like the "show article summary" is respected on the first RSS account,
but not on the others.  I my case I have two, and I have added some of the same
feeds to both.  In the first account the summary is shown, and in the other
account the web page is shown.

Comment 4

14 years ago
Duplicate of bug 259018 (claims that this bug "only affects new items")?

*** This bug has been marked as a duplicate of 259018 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 6

13 years ago
I don't think this is a duplicate of bug 259018.  That bug describes the expected (but poorly documented) behavior of the "show summaries" option, i.e. that it only affects items downloaded after the setting is changed.  This bug is about the option being ignored after the feed is downloaded the first time.

The same thing is happening for me with Thunderbird 1.5 20051201 on Windows XP.  I add an RSS feed with the show summaries option checked both in the feed and in the account, but the next time I open Thunderbird and load the feed, the new items are shown as full web pages, even though the show summaries option is still checked.

Updated

10 years ago
Component: RSS → Feed Reader
Product: Thunderbird → MailNews Core
You need to log in before you can comment on or make changes to this bug.