Can't save external .css files with "@import" rule (2 cases)

VERIFIED DUPLICATE of bug 126309

Status

()

VERIFIED DUPLICATE of bug 126309
14 years ago
14 years ago

People

(Reporter: dekomb, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Build Identifier: Firefox 1.0

external .css files are not saved with "save as" in the both cases :
- the .css file is linked with the "@import" rule instead of the <link> one.
(already reported : bugs #235791 & #126309) 
- a second .css file is imported in the first .css file with the "@import" 
rule. in this case this is the second .css file which is not saved. 

Reproducible: Always

Steps to Reproduce:
1."save as" the specific page (cf. URL above)
2.open the saved .html file
3.compare the aspects
4.open the "style/weblog_guepe.css" saved, and find a " @import url
(commun_guepe.css) " rule (1st line) and notice that commun_guepe.css had not 
been saved.   

Actual Results:  
1. the aspect of the page saved is different from the original
2. the second commun_guepe.css file and its related files are not saved.  

Expected Results:  
seek the @imported .css files and related in the both cases.

Comment 1

14 years ago
See Bug 126309 "save page does not save @import -ed CSS"

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 126309 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
If it's already reported, why did you open another bug? Case 2 is essentially
the same as case 1.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.