View Message Source - Save Page As is broken

RESOLVED DUPLICATE of bug 287490

Status

RESOLVED DUPLICATE of bug 287490
14 years ago
14 years ago

People

(Reporter: steffen.wilberg, Assigned: mscott)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
1. Let Thunderbird display a message.
2. Hit Ctrl+U.
3. Click File > Save Page As and save the message.

Results:
The saving dialog doesn't succeed and stays open.
The js console displays:
Error: uncaught exception: [Exception... "Component returned failure code:
0x80004002 (NS_NOINTERFACE) [nsITransfer.init]"  nsresult: "0x80004002
(NS_NOINTERFACE)"  location: "JS frame ::
chrome://communicator/content/contentAreaUtils.js :: internalSave :: line 376" 
data: no]

This is unrelated to bug 222157: It doesn't work without those changes either;
on the contrary, bug 222157 was supposed to make Save Page As work again by
referencing XPCNativeWrapper.js in viewSource.xul:
http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&subdir=mozilla/toolkit/components/viewsource/content&command=DIFF_FRAMESET&file=viewSource.xul&rev1=1.18&rev2=1.19&root=/cvsroot
please don't assign random bugs to me

that said, may well have the same cause as Bug 287490
Assignee: cbiesinger → mscott
(Reporter)

Comment 2

14 years ago
Sorry, I should've cc'ed you instead.
Since ViewSource-SaveAs uses the progress dialog as well, and the error is
displayed in the js console, this looks indeed like a dupe of bug 287490.

*** This bug has been marked as a duplicate of 287490 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.