Define an address book interface for use in Sunbird

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
14 years ago
5 years ago

People

(Reporter: stelian, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050302 Firefox/1.0.1 Fedora/1.0.1-1.3.2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050302 Firefox/1.0.1 Fedora/1.0.1-1.3.2

Sunbird would need an addressbook infrastructure which would let the user select
the attendees for an event in an addressbook.

This infrastructure would be based on backends, which would make the developers
able to propose LDAP-based addressbooks, or Thunderbird-shared addressbooks or
GroupDAV remote addressbooks.

The best solution would be to reuse the mailnews/adrbook code and make it usable
outside mailnews. But this is a long term solution.

My proposal is to define a very simple, calendar only, addressbook
infrastructure. This will create the conditions to develop the Sunbird UI and
the addressbook providers we need immediately. Once the 'real' addressbook is
available, it should be easy to switch the code to use it. 

A patch implementing this infrastructure (modeled after the calendar
infrastructure) is attached to this bug, feedback is welcomed.

Reproducible: Always
(Reporter)

Comment 1

14 years ago
Created attachment 178471 [details] [diff] [review]
Patch implementing this infrastructure
I personally don't like to create a new temporary solution. They then to not be
temporary.
I rather have this fixed the right way, maybe by moving the addressbook stuff
into toolkit. (but firefox doesn't want it. Maybe something even smarter?)

Updated

14 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All
Unfortunately, I do not have cycles to work on Calendar stuff these days (just as it's getting to the good part!), so I am a bad owner for these bugs.  To delete the tragically-large chunk of bugspam, search for gregorianabdication.
Assignee: shaver → nobody

Comment 4

12 years ago
There is already a similar bug: https://bugzilla.mozilla.org/show_bug.cgi?id=361846

Comment 5

12 years ago
I agree with Michiel's comment. I'd rather spend cycles on a long term fix rather than a temporary one.

I can see a case for sunbird having its own addressbook, but I think a more usable solution would be to have your addressbook tied to your email client. This way the email client can automatically add people to your addressbook without you having to do anything, and it seems a more logical place to manage addresses.  

In that light, I would like to see an ability for Sunbird to make use of existing addressbook stores on the machine, rather than have its own addressbook integrated into it.  

Comment 6

12 years ago
Changing component to Sunbird Only
Component: Internal Components → Sunbird Only
QA Contact: base → sunbird

Updated

12 years ago
Duplicate of this bug: 361846

Comment 8

12 years ago
As I wrote in the comment in Bug 361846 my idea would be to decouple the address book from Thunderbird and make it an extension. This way it could be added to Sunbird as well. And if a user would like to have another address book he can choose (or write) another extension.

Comment 9

12 years ago
maybe just having Sunbird launch Thunderbird's addressbook would be sufficient. Like how Firefox would launch thunderbird's compose mail window when you want to write a email.
(In reply to comment #9)
> maybe just having Sunbird launch Thunderbird's addressbook would be sufficient.
> Like how Firefox would launch thunderbird's compose mail window when you want
> to write a email.

We could just call Thunderbird with the -addressbook commandline parameter.

Comment 11

12 years ago
You need Thunderbird anyway to do a lot of the features in planning e.g. Invitations. If people don't like it then we can just change it.

Comment 12

12 years ago
I agree with you. One reason why I don't want to "hard link" it too much is because I have more address "containers" in the future. One idea would be to look up an attendant with the jabber directory. And send the invitation as an instant message. (or other IM services, maybe Skype wants to write a plug-in as well...)

(I think that maybe the Thunderbird programmers should say as well in what direction they want to go with their address book anyway)

Comment 13

11 years ago
I think it would be a good ide to use the Thunderbird's adresse books, but Sunbird would have to handle adresse books by it self, if the user don't have Thunderbird installed on the PC/Mac.

Could it be an ide to have some sort of common adresse books for alle Mozilla applications ?
Severity: normal → enhancement
Summary: Define an addressbook interface for use in the Calendar → Define an address book interface for use in Sunbird
Resolving as WONTFIX because Sunbird has been discontinued and the code has been removed from the project.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.