Firefox profile installed on memory stick makes Firefox hangs

RESOLVED DUPLICATE of bug 157662

Status

()

Toolkit
Startup and Profile System
--
major
RESOLVED DUPLICATE of bug 157662
13 years ago
4 years ago

People

(Reporter: Philippe GOETZ, Assigned: Benjamin Smedberg)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.6) Gecko/20050223 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.6) Gecko/20050223 Firefox/1.0.1

There is a major difference in the baseURL between the chrome.rdf in
resource:/chrome and the one in the profile. The baseURL in the chrome.rdf in
profile used file: protocol with absolute address, while the standard one use
resources: protocol which is a relative protocol.

This major difference will make unusable a profile stored on a memory stick as
soon as you install an extension in the profile.

Reproducible: Always

Steps to Reproduce:
1. Install the profile on a memory stick
2. Install an extension
3. Reinstall the memory stick with another drive letter
4. Firefox hangs



As it exists a resource: protocol, it will worth to have a profile: protocol,
which will remove any absolute reference to the profile through the file: protocol.
(Assignee)

Comment 1

13 years ago
This is a dup of the "use relative paths in profile contents.rdf" bug, which was
fixed recently. Please search for dups before filing new bugs.
Whiteboard: DUPEME

Comment 2

13 years ago
Dupe of bug 157662.

*** This bug has been marked as a duplicate of 157662 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 3

13 years ago
That's the wrong dup, but whatever...
Product: Firefox → Toolkit

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.