POST and GET Request send twice

RESOLVED DUPLICATE of bug 61363

Status

()

Core
HTML: Parser
--
major
RESOLVED DUPLICATE of bug 61363
13 years ago
13 years ago

People

(Reporter: Felix Stellmacher, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041220 K-Meleon/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041220 K-Meleon/0.9

If e.g. debug information in scripts ar printed out before the <DOCTYPE...
firefox sends the same request twice to the destination.

This is serious for scripts. Actions are performed twice!! We are unfortunately
not able to use firefox futher on for developement issus!

We figured out this behaviour in the 1.0 Version but it seemed to be a single
failure. Now in 1.0.2 we can reproduce the behaviour on any server with any client.

Thanks in advance!
Felix

Reproducible: Always

Steps to Reproduce:
1. open any PHP script in the browser (firefox 1.0.2 and before)
2. print debug information e.g. "TEST"
3. print the html valid html source of a page beginning with the doctype , aso.

Actual Results:  
the browser sends the request twice

Expected Results:  
send the request one single time
Can this bug be reproduced with the latest Trunk build?
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2005-03-24-07-trunk/

Comment 2

13 years ago
Instead of outputing invalid HTML, why not place the "debug information as HTML
comment into the HTML?

Updated

13 years ago
Severity: blocker → major
(Reporter)

Comment 3

13 years ago
Hi Steve,
I just tried to reproduce the behaviour with the firefox Version that you gave me.
Unfortunately with success.

Hi Ng Ming,
the actual problem is, that hundreds of websites hosted on our servers are
unfortunately not valid - and double load of these websites and the problems
caused by this will increase our support :(

Comment 4

13 years ago
Other bugs POST send twice ended up being duped to bug 61363, can you please
read that bug and see if that is the issue you are having?
Assignee: firefox → parser
Component: General → HTML: Parser
Product: Firefox → Core
QA Contact: general → mrbkap
Version: unspecified → Trunk
(Reporter)

Comment 5

13 years ago
Hi José,
I'm afraid yes, my report is a duplicate of this bug - sorry for this! It seems
to be a well known problem mh? Hopefully you guys can fix it soon. 

*** This bug has been marked as a duplicate of 61363 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.