Recent builds seem to be less tolerant of misplaced <BGCOLOR="#CCFFFF"> in form

RESOLVED DUPLICATE of bug 287349

Status

Camino Graveyard
HTML Form Controls
RESOLVED DUPLICATE of bug 287349
13 years ago
13 years ago

People

(Reporter: Robert M. Rhode, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O) Gecko/20040906 Camino/0.8+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O) Gecko/20040906 Camino/0.8+

Recent builds now seem to allow the misplaced <BGCOLOR="#CCFFFF"> line in the
following html fragment to break the drop down menu. Slightly older builds seem
to handle this foolishness ok.



!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>

<head>
<title>Untitled Document</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
</head>
<body>
<tr><td align=middle><FORM NAME="dropdown">
               <SELECT NAME="EXAMPLE" onChange='newpage();' ALIGN="left">
<BGCOLOR="#CCFFFF">
<option selected >Option 0:
<option>Option One
<OPTION>Option 10
<OPTION>Option III

</SELECT>

</form>
</td>
</tr>

</body>
</html>


Reproducible: Always

Steps to Reproduce:
1. Check code fraqment
2.
3.

Actual Results:  
Dumps options as text

Expected Results:  
Treat options as elements of drop down menu
(Assignee)

Comment 1

13 years ago
can you be more specific on which nightly this started happening?
(Reporter)

Comment 2

13 years ago
The last build that tolerates the misplaced <BGCOLOR="#CCFFFF"> in the code
sample is March 17 2005. From the March 18 2005 build on the code sample causes
a problem.
(Assignee)

Comment 3

13 years ago
awesome, thanks. i assume this happens in FF as well, if so, it's a core bug.
can someone test?

Comment 4

13 years ago
WFM with Camino 20050324 and Firefox 20050324.

*** This bug has been marked as a duplicate of 287349 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.