a problem with opening files with non-english characters in pathname or filename

RESOLVED DUPLICATE of bug 263570

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 263570
13 years ago
13 years ago

People

(Reporter: videoj, Assigned: Blake Ross)

Tracking

1.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050223 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050223 Firefox/1.0.1

if you try to open file with its name or path containing non-english characters
while another file with non-english name is already opened, you get the alert
message "file cannot be found".

Reproducible: Always

Steps to Reproduce:
1. open file with non-english path by double-click. everything's ok.
2. open the second file with non-english path by double-click.
Actual Results:  
the message "file cannot be found" appears and the second file isn't opened.

Expected Results:  
no messages and just open the second file
Whiteboard: dupeme

Comment 1

13 years ago
What are you specifically trying to open?  What type of file?  Is the file you
are trying to open already opened by another process?  What language were the
files in?  We need some more details here.  Perhaps a testcase, upload a couple
of files to test with?  I can't attempt to reproduce with incomplete information
and no knowledge of what to use for testing.  

Changing severity to Normal.
CCing myself
Severity: critical → normal
(Reporter)

Comment 2

13 years ago
it seems to appear with any types of files (pictures or htmls).
i'm sure the file isn't in use by another process.
the language is russian, and using russian Win XP SP2.
this problem accurs even in FF clear of any extensions.
in seamonkey mozilla (1.7.2 and any later i think) this problem doesn't appear.
(Reporter)

Comment 3

13 years ago
Created attachment 178550 [details]
file with russian filename

Comment 4

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050323
Firefox/1.0+

WFM for me with the file provided, but I am not sure that the file you uploaded
is retaining the Russian characters, since when opened it escapes it as an
extended ASCII character.  I am not sure I can reproduce without being on a
Russian version of Windows/Linux, so I am not going to close this bug, but I am
unfortunately unable to confirm it as well.
(Reporter)

Comment 5

13 years ago
Created attachment 178602 [details]
video in divx. firefox 101

i made video to illustrate the situation
(Reporter)

Comment 6

13 years ago
Created attachment 178603 [details]
video in divx. mozilla suite 1.7.2

also video with mozilla suite. i captured it to show how mozilla suite goes
with the same operations as in firefox case.

Comment 7

13 years ago
Please search before filing new bugs.

*** This bug has been marked as a duplicate of 263570 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Whiteboard: dupeme
Version: unspecified → 1.0 Branch
You need to log in before you can comment on or make changes to this bug.