overflow:hidden causes rendering issue in Print Preview

RESOLVED DUPLICATE of bug 129941

Status

()

Core
Layout: View Rendering
RESOLVED DUPLICATE of bug 129941
13 years ago
11 years ago

People

(Reporter: Oli Charlesworth, Assigned: roc)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.6) Gecko/20050321 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.6) Gecko/20050321 Firefox/1.0.2

It seems that for an HTML block with its CSS "overflow" style set to "hidden"
that should be clipped by the "page" boundary in Print Preview, it actually
spills onto the grey background below the page.

Reproducible: Always

Steps to Reproduce:
1. Create an HTML page with a <DIV style="overflow:hidden"> element with enough
content to require more than one printable page (use the example I posted:
http://olifilth.co.uk/41.htm).
2. View in Mozilla
3. Go to Print Preview

Actual Results:  
Text content spills onto background below visible pages in Print Preview.

Expected Results:  
Should've been clipped at the edges of the visible page.
(Reporter)

Comment 1

13 years ago
Oops, wrong user-agent string. Should've been:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050324

Comment 2

13 years ago
Confirmed
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b) Gecko/20050217

Comment 3

13 years ago
Confirmed New since also in latest nightly
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050328

Changing to Core, Print Preview
Status: UNCONFIRMED → NEW
Component: General → Print Preview
Ever confirmed: true
Product: Mozilla Application Suite → Core
Version: unspecified → Trunk
Over to view rendering.  Reporter, could you please attach the testcase to the bug?
Assignee: general → roc
Component: Print Preview → Layout: View Rendering
QA Contact: general → ian
(Reporter)

Comment 5

13 years ago
Created attachment 180726 [details]
Testcase demonstrating the overflow problem

Comment 6

11 years ago
Is this bug also the reason why printing doesn't work properly on this page: http://aftonbladet.se/vss/nyheter/story/utskrift/0,3258,1030980,00.html

The appearance of that page seems to be similar to this testcase when selecting Print Preview.

Comment 7

11 years ago
marking as a dup of bug 129941 b/c it describes the same problem and at least has some code contributed to it, albeit fairly old.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 129941
You need to log in before you can comment on or make changes to this bug.