The "newest additions" RSS feed on the Mozilla Update home page uses incorrect URLs

RESOLVED DUPLICATE of bug 278394

Status

addons.mozilla.org Graveyard
Public Pages
RESOLVED DUPLICATE of bug 278394
13 years ago
2 years ago

People

(Reporter: Alan Holding, Assigned: alanjstr)

Tracking

unspecified
x86
Windows XP

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.6) Gecko/20050321 Firefox/1.0.2 StumbleUpon/1.9993
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.6) Gecko/20050321 Firefox/1.0.2 StumbleUpon/1.9993

The Newest Additions RSS feed is using incorrect URLs which result in 404 Not
Found errors.

Reproducible: Always

Steps to Reproduce:
1. I subscribed to the "newest additions" RSS feed
(https://addons.update.mozilla.org/rss/?application=firefox&list=newest) on the
Mozilla Update home page (https://addons.update.mozilla.org/).

2. I placed the RSS feed as a live bookmark in the Bookmarks Toolbar in Firefox
(Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.6) Gecko/20050321
Firefox/1.0.2).

3. As an example of the bug with the RSS feed (not the extension I'm linking to
here), the link to the page about Table Inspector 0.1 for Firefox uses this URL
- https://addons.update.mozilla.org/moreinfo.php?id=464&vid=1562 - which gets me
a 404 Not Found error.

The link to Table Inspector 0.1 for Firefox on the Mozilla Update home page (in
the Newest Additions section) uses a different URL -
https://addons.update.mozilla.org/extensions/moreinfo.php?application=firefox&version=1.0&os=Windows&id=464
- which works fine.

So, to clarify this example...

Bad URL:
https://addons.update.mozilla.org/moreinfo.php?id=464&vid=1562

Good URL:
https://addons.update.mozilla.org/extensions/moreinfo.php?application=firefox&version=1.0&os=Windows&id=464
Actual Results:  
404 Not Found error when clicking a link in the RSS feed.

Expected Results:  
Taken me to the correct page on Mozilla Update.
(Assignee)

Updated

13 years ago
Whiteboard: Dupeme
(Assignee)

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 278394 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

4 years ago
Whiteboard: Dupeme
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.