Firefox crashes after few seconds of mangle.cgi [@ nsPluginTag::RegisterWithCategoryManager ]

VERIFIED DUPLICATE of bug 287690

Status

()

defect
--
critical
VERIFIED DUPLICATE of bug 287690
14 years ago
8 years ago

People

(Reporter: pavel.penaz, Assigned: bugzilla)

Tracking

({crash, testcase})

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050325 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050325 Firefox/1.0+

Todays trunk builds crash after few seconds of running the mangle.cgi script
locally. From my observation this crash does not occur because of the invalid
HTML (FF renders the page on which it crashed quite fine) but perhaps because of
the fast page reloads or something like that. Try running mangle.cgi at this
link: http://84.242.65.71/cgi-bin/mangle.cgi but it is possible that you'll need
to run the script locally to cause the crashing.

Some talkback IDs: TB4593169Y, TB4593130E, TB4593103X, TB4593080X, TB4593057Q

Reproducible: Always
(Reporter)

Comment 1

14 years ago
Sorry if this is a duplicate but talkback servers are not working. Marking as
depending on bug 264944.
Depends on: Zalewski
(Reporter)

Comment 2

14 years ago
This link reliably crashes my Firefox:
http://84.242.65.71/cgi-bin/remangle.cgi?0x49e81441

Comment 3

14 years ago
The dependency was the wrong way round. Correcting so that this bug blocks bug
264944 like all the other similar crashes.
Blocks: Zalewski
No longer depends on: Zalewski
(Reporter)

Comment 4

14 years ago
Thanks for correcting my mistake.
I have spent last hour trying to come up with a working reduced testcase but I
haven't suceeded. The link above works though and FF crashes after meta-refresh.
(Reporter)

Updated

14 years ago
Keywords: crash, testcase
Summary: Firefox crashes after few seconds of mangle.cgi → Firefox crashes after few seconds of mangle.cgi [@ nsPluginTag::RegisterWithCategoryManager 57351e2d]
(Reporter)

Comment 5

14 years ago
It has something to do with Java applets. I get the same talkback on this page:
http://www.broadbandreports.com/tweaks
(Reporter)

Comment 6

14 years ago
(Reporter)

Comment 7

14 years ago
WFM with yesterday's build



*** This bug has been marked as a duplicate of 287690 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Updated

14 years ago
Status: RESOLVED → VERIFIED

Updated

14 years ago
Summary: Firefox crashes after few seconds of mangle.cgi [@ nsPluginTag::RegisterWithCategoryManager 57351e2d] → Firefox crashes after few seconds of mangle.cgi [@ nsPluginTag::RegisterWithCategoryManager ]
Crash Signature: [@ nsPluginTag::RegisterWithCategoryManager ]
You need to log in before you can comment on or make changes to this bug.