asynchronous updates to the template builder sometimes failing

VERIFIED WORKSFORME

Status

()

Core
RDF
P3
normal
VERIFIED WORKSFORME
19 years ago
19 years ago

People

(Reporter: Alec Flett, Assigned: Chris Waterson)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
On today's build, we've seen a few odd problems with the tree (though I think
it's actually the template builder) that I'm guessing are all related.
- items don't always appear in the tree - for example, when you get new mail,
you don't always see the new messages in the thread pane, you have to go to
another pane, then re-enter the current one.\
- if you create and delete accounts over and over, sometimes the account does
not appear in the folder pane, sometimes it does. I've even had two trees open
(the folder pane and the account manager) and had the account show up in one
tree and not show up in the other
- you can't always delete a message - sometimes the message just won't go away.
- putterman says he's having trouble with the twisty not opening in the thread
pane.

The problem is that the behavior is very inconsistent. for me this was only
happening (I was creating/deleting alot of accounts) about 1 out of 10 times.
I'm guessing it's easier to track down with new messages. (mscott can comment)

Assigning to waterson because his changes to nsRDFGenericBuilder.cpp look the
most suspect, but CC'ing hyatt because the tree seems to have changed ver so
slightly too. add putterman and mscott because they've seen this odd behavior
(Assignee)

Comment 1

19 years ago
You could try backing out my changes to nsXULDocument.cpp and 
nsRDFGenericBuilder.cpp. But, I'm pretty sure that this is another incarnation 
of bug 24546, the <template> builder cannot handle some assertion orderings. 
Specifically, the builder requires that assertions be "bottom up", that is, that 
the last assertion actually connects a new element to the container.

I'm not sure how to proceed with this. If you can isolate a test case, I'd be 
happy to look at it, but as is, it's pretty underspecified...
(Assignee)

Updated

19 years ago
Target Milestone: M15
(Assignee)

Comment 2

19 years ago
Anyone still seeing this problem?
(Reporter)

Comment 3

19 years ago
I saw it on yesterday's build, just started working with today's build.
(Assignee)

Comment 4

19 years ago
feh
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

19 years ago
:)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.