linux, win: selecting Copy doesn't dismiss context menus

VERIFIED WORKSFORME

Status

()

P2
normal
VERIFIED WORKSFORME
19 years ago
10 years ago

People

(Reporter: bugzilla, Assigned: mikepinkerton)

Tracking

({helpwanted, platform-parity, regression})

Trunk
Future
x86
Linux
helpwanted, platform-parity, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2-])

(Reporter)

Description

19 years ago
found this while using today's opt comm bits on linux and winNT [2000022108];
not a problem on mac. i know there are currently problems w/pasting (eg, bug
26668, bug 19428, if applicable), so feel free to reassign, add dependencies,
etc (or, dup if called for).

1. go to any webpage, eg, http://bugzilla.mozilla.org
2. select some text in the content.
3. bring up context menu. the Copy item is active (expected).
4. select Copy (which requires use of left mouse button --bug 17159).

observe: after selecting, the Copy item does grey-out (expected), but the
context menu doesn't go away.
(Reporter)

Comment 1

19 years ago
nominating for beta1...?
Keywords: beta1, pp, regression
Summary: selecting Copy doesn't dismiss context menus → linux, win: selecting Copy doesn't dismiss context menus
(Assignee)

Comment 2

19 years ago
this is _so_ weird. accepting for m14, p2
Status: NEW → ASSIGNED
Priority: P3 → P2
Target Milestone: M14

Comment 3

19 years ago
Isn't the workaround to use the pull down menus?
Whiteboard: [PDT-]

Comment 4

19 years ago
Another work around: The first time you bring up a context menu on a page, 
select "Select All". Now "Copy" dismisses the context menu until you load 
another page.
(Assignee)

Comment 5

19 years ago
moving to m15
Target Milestone: M14 → M15
(Assignee)

Updated

19 years ago
Target Milestone: M15 → M16

Comment 6

19 years ago
*** Bug 34272 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 7

19 years ago
pushing off
Target Milestone: M16 → M17

Comment 8

19 years ago
*** Bug 34233 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

19 years ago
Keywords: beta1 → nsbeta2
Whiteboard: [PDT-]

Comment 9

19 years ago
[nsbeta2-]
Whiteboard: [nsbeta2-]
(Assignee)

Comment 10

19 years ago
*** Bug 39865 has been marked as a duplicate of this bug. ***

Comment 11

19 years ago
Mass-moving all nsbeta2- bugs to M20
Target Milestone: M17 → M20
(Reporter)

Comment 12

19 years ago
*spam*: transferring current XP Menu bugs over to jrgm, the new component owner.
feel free to add me to the cc list (unless am the Reporter) of any of these, if
you have any questions/etc.
QA Contact: sairuh → jrgm

Comment 13

19 years ago
No time left for minor flaws, futuring.
Target Milestone: M20 → Future

Comment 14

19 years ago
Just goes straight from beta2- to future if there's no time to put it in beta2?
(Assignee)

Comment 15

19 years ago
there's probably no time in beta3 either is what trudelle is saying. have you 
_seen_ my buglist?
(Reporter)

Comment 16

19 years ago
adding helpwanted and 4xp since this [imo] is one those interface behaviors
(after selecting a context menu item, the context menu shouldn't persist) that
many users take for granted.
Keywords: 4xp, helpwanted

Comment 17

19 years ago
I am in no way dismissing the size or complexity of your buglist. I am just 
asking because this is a basic behavior of any application. Things like this 
will drive the new users away saying, "what a POS. They can't even make the 
menus work right". They do not understand the complexities of XUL, XBL, etc., 
but all that cool technology won't matter if they don't adopt it. Sorry to 
editorialize in a bug comment, but percieved instability is of the utmost 
importance here. The one Web development group I frequent 
(macromedia.dreamweaver) is almost unanimous in hating Netscape 6 because of a 
percieved "weirdness" in how the interface behaves. I, like you I'm sure, am 
very concerned about how well Mozilla/Netscape6 will be recieved, and this kind 
of stuff is already driving people away.
(Assignee)

Comment 18

19 years ago
*** Bug 46005 has been marked as a duplicate of this bug. ***

Comment 19

18 years ago
I don't see this in Linux M17 release. I suspect it just vanished some time in
the last six months, or is skin-specific (I'm using Classic) in either case I'd
be happy to see WORKSFORME and VERIFY from those qualified to do so.
(Assignee)

Comment 20

18 years ago
I don't see this in the 10/23/00 branch win32 builds, or the linux trunk builds.
I tried with both modern and classic skins in composer and mail.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 21

18 years ago
i cannot seem to repro this using today's comm branch bits on linux,
2000.10.24.09-n6. anyone else?

Comment 22

18 years ago
I can't reproduce it, the text does gray out and the menu goes away, build 
2000-10-24-09 mn6

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 23

18 years ago
Thanks, all .... outta here.

Comment 24

17 years ago
Mass removing self from CC list.

Comment 25

17 years ago
Now I feel sumb because I have to add back. Sorry for the spam.

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.