Script box "A script on this page is causing Mozilla to run slowly" coming up too much!

RESOLVED DUPLICATE of bug 230909

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 230909
13 years ago
13 years ago

People

(Reporter: Shaun, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

I am running a script to save my emails (autosave extension) and am doing a
large batch and the script box keeps popping up telling me to either stop the
script or cancel.

Unless this thing is suppose to have it so users are forced to press cancel
100's of times, I'd like this thing to pop up only once per script (or time
period, say 30 min) so i can say cancel to keep running the script.

Thanks for your help and volunteering your time :o)



Reproducible: Always

Steps to Reproduce:
1.Highlight a lot of files
2.Export them to a folder
3.

Actual Results:  
The box keeps coming back saying "A script on this page is causing Mozilla to
run slowly...DO you want to abort the script" and I say 'cancel' to have it keep
going (since I want to save the files) but the box won't listen, it keeps coming
back.

Expected Results:  
I want the warning box to get out of my face and allow the script to back up my
emails without me having to click 'cancel' 100's of times :).

Comment 1

13 years ago
dom.max_script_run_time might help as suggested by bug 250841 comment 6
more info at http://kb.mozillazine.org/About:config

DUPLICATE bug 230909 xref bug 78089 

*** This bug has been marked as a duplicate of 230909 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.