NetscapeSetup crashes after all .xpi files are downloaded

VERIFIED FIXED

Status

P3
normal
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: chriss, Assigned: dougt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
While installing the 2-21-17 M14 commercial build, NetscapeSetup crashes after 
downloading the last .xpi file. The following Win98 error message is displayed:

SETUP caused an invalid page fault in
module XPCOM.DLL at 0177:60c580b8.
Registers:
EAX=010d0e80 CS=0177 EIP=60c580b8 EFLGS=00010246
EBX=00000000 SS=017f ESP=006779e4 EBP=006779f0
ECX=60c6c80c DS=017f ESI=780125c8 FS=4b87
EDX=00000003 ES=017f EDI=010d4a70 GS=0000
Bytes at CS:EIP:
83 23 00 6a 26 68 60 3f c8 60 c7 00 01 00 00 00 
Stack dump:
80000000 010d0e80 00000000 00677a3c 60c42948 010d4a58 60c83844 010d0e80 00000000 
60c53ea7 00000000 60c454a2 010d08f0 60c45513 010d0920 010d08f0
(Reporter)

Comment 1

19 years ago
MArking beta1, dogfood since I can't install the commercial build
Keywords: beta1, dogfood

Comment 2

19 years ago
NT4 seems fine, but then I have a build from Friday.  I'll try a fresher build 
and on Win98.
Status: NEW → ASSIGNED

Comment 3

19 years ago
reproduced this on Win98 with 2-21-17 build 
also on NT (bug 28771 ?) did not lose connectivity 

build 2000022109 did not exhibit this behavior

Comment 4

19 years ago
build 2000022209 crashing right after 'preparing to install' message

Comment 5

19 years ago
traced down to a possible file dougt updated yesterday.  Reassigning to him.
Assignee: ssu → dougt
Status: ASSIGNED → NEW
(Assignee)

Comment 6

19 years ago
fix checked in
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 7

19 years ago
*** Bug 28839 has been marked as a duplicate of this bug. ***

Comment 8

19 years ago
changing platform to all- occurring on Mac also
Status: RESOLVED → VERIFIED
OS: Windows 98 → All
Hardware: PC → All

Comment 9

19 years ago
my bad-hit verified----but not yet
will reopen and mark
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Comment 10

19 years ago
remarking resolved/fixed 
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED

Comment 11

19 years ago
After chatting with ssu and comparing stack crawls it seems that the Mac dies in 
NS_InitXPCOM() too.  Hoping this will fix the Mac too.

JJ,
We'll need to respin xpcom.shlb and repackage install.xpi to produce a working 
installer (which also means changing swapping in the repackaged install.xpi in 
MozMacInstaller.sea.bin for today's 11am installer build).  

Comment 12

19 years ago
*** Bug 28895 has been marked as a duplicate of this bug. ***

Comment 13

19 years ago
on build 2000022218- I am crashing before any downloads - right after pressing 
install button

Comment 14

19 years ago
ok on build 2000-02-23-09
my error on last build
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.