RSS item content not shown with redirected URL

RESOLVED INVALID

Status

MailNews Core
Feed Reader
RESOLVED INVALID
14 years ago
5 years ago

People

(Reporter: zuxy.meng, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)
Build Identifier: 

When you subscribe to any RSS feed found on the page mentioned above, e.g 
http://rss.yesky.com/360287970189639680.xml, Thunderbird can retrive the 
titles, but when you click on a certain title, it can't show the content.

Reproducible: Always

Steps to Reproduce:
1.Subscribe to http://rss.yesky.com/360287970189639680.xml
2.Click on any title in the upper-right panel
3.

Actual Results:  
Nothing appears in the lower-right panel.

Expected Results:  
Show the details in the lower-right panel.

Two versions behave the same way:

Thundermail 0.9 rpm package built for Fedora core 3
Thundermail 1.0.2 for Win32 downloaded from www.mozilla.org

Comment 1

14 years ago
I wonder if it's because each page served by the feed is a redirecting URL;
see bug 272971 (but ignore cmt #1 there, which is irrelevant).

For this particular feed, if you use   View | Message Body As | Simple HTML
you will get a string of Chinese.  But with Original HTML, TB appears to be 
fetching the page, but doesn't render anything.  Reproduced with TB 1.0+0320, 
Win2K.

If you configure the feed to Show Article Summary, then using either View|
Message Body setting will show you the same string of text.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → Windows 2000
Version: unspecified → Trunk
(Reporter)

Comment 2

13 years ago
The bug persists in Thunderbird 1.0.6.
OS: Windows 2000 → Windows XP
Version: Trunk → 1.0

Comment 3

13 years ago
(In reply to comment #2)
> The bug persists in Thunderbird 1.0.6.

For the purposes of reporting bugs, that's unimportant.  You should be testing 
with 1.5b2, at the very oldest.  Most, if not all, of the RSS bugfixes since the 
1.0 branch are in 1.5b2.
  http://www.mozilla.org/products/thunderbird/all-beta.html

Comment 4

13 years ago
*** Bug 323279 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Summary: can retrieve only the title, can't show the content under any title → RSS item content not shown with redirected URL
Version: 1.0 → Trunk

Comment 5

12 years ago
I had similar Problems with 1.5.0.7 on Gnome on Fedora Core 5. For no Reason I can imagine, the View changed to "Plain Text", which did not show anything. When I turned back to "Full HTML" the content appeared back again. This happened several times for no apparent reason. I had this problem with several RSS feeds.
QA Contact: rss

Updated

10 years ago
Assignee: mscott → nobody

Updated

9 years ago
Component: RSS → Feed Reader
Product: Thunderbird → MailNews Core

Comment 6

5 years ago
the <link> redirect doesn't work in Fx so this example is publisher error.  in general, a redirect link, and show web page option, should result is a successful redirect.  as for the url in bug 272971.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.