Canceling update to 1.0.2 causes FF to crash and must be re-installed

RESOLVED DUPLICATE of bug 283680

Status

()

Toolkit
Application Update
--
major
RESOLVED DUPLICATE of bug 283680
13 years ago
10 years ago

People

(Reporter: Johan Soderstrom, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

1.7 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

When updating Firefox through the automatic updater but pressing Cancel at the
last (?) step Firefox will not handle this situation correctly. Sadly I did not
make any screenshots. This maked firefox unable to start (ever - for me at
least) when closed. A reinstall was needed... This is why I label this bug as
critical - even though I think I'm the only one affected because people just
don't press Cancel there!!!


Reproducible: Always

Steps to Reproduce:
1. I pressed the updater icon
2. I pressed install.
3. I went through 3-4 steps (can't remember how many, sorry) but I do know I
pressed Cancel at one point. As far as I can rememer it was when the last
quastion "Should I install this" or something like that popped up...
4. I still wanted the update, but the update icon was missing, so I restarted
firefox (tried to)...
Actual Results:  
Result: firefox tells me that "??? is still running and I need to close the
application for the update to finish" or something like that, again I'm sorry I
wasn't paying attention... Note that no error was reported, so this is all I can
give you guys...

Dirty fix: Download the entire installer and re-install everything...

Well, I think that I'm the only one stupid enough to press cancel at that stage,
so this is probably a bug that you'll only see once... BUT on the other hand it
rendered firefox unusuable...

Expected Results:  
It should have started up as normal.... or something... not hanging
I've seen the same behavior. To get Firefox working again, delete the
"xpicleanup.dat" file in your program directory.
See bug 283680 comment 14.

*** This bug has been marked as a duplicate of 283680 ***
Severity: critical → major
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Version: unspecified → 1.0 Branch
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.