Firefox crashes while using Java version 1.5.0

RESOLVED DUPLICATE of bug 285390

Status

()

--
critical
RESOLVED DUPLICATE of bug 285390
14 years ago
13 years ago

People

(Reporter: firefox_bugs, Assigned: bugzilla)

Tracking

({crash, qawanted})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

While using Firefox on Windows XP Professional and accessing a website 
that uses Java the browser will eventually crash. I am using the newest 
version of Java 1.5.0. I upgraded Firefox from 1.0 to 1.0.1 to 1.0.2 
that didn't help. I updated Java from 1.5.0_01 to 1.5.0_02 and the 
crash still occurs. I'm not sure if this is a Java or Firefox problem, 
this problem does not occur in Internet Explorer. I mainly use Java to 
play internet games at http://games.yahoo.com. The crash occurs 
when I am closing out a table, switching rooms, checking out player information
or logging out. This problem never occured with java verion 1.4.1 or 1.4.2.

Reproducible: Always

Steps to Reproduce:
1. install java version 1.5.0
2. install firefox
3. go to http://games.yahoo.com  (you have to have an account)
4. log in
5. Once you start playing the browser will eventually crash

Actual Results:  
It eventually crashed sometime in the course of being logged in and 
playing yahoo dominoes.

Expected Results:  
Even if java becomes unstable and crashes, it should not crash the 
browser.

This problem has occured on three different computers all running 
Windows XP PRO. One of the computes is a Pentium III 550 MZ:128mb ram, the second 
is a Pentium 4 3.4 GZ:1GB ram, and the third is a AMD Athlon 3300+:512mb ram.

It does not give me a module in which the software crashed.
Reporter, could you try with a more recent trunk build please?
http://www.ftp.uni-erlangen.de/pub/mozilla.org/firefox/nightly/2005-03-26-07-trunk/
And just to clarify, you're using the latest Java right? 1.5.0 beta2 right?
Reporter:
Did you try to run Firefox in teh safemode ?

Updated

14 years ago
Keywords: crash

Comment 3

14 years ago
Even crashes with Java 2

Comment 4

14 years ago
This is a dupe, please use the search function before filing a bug.

*** This bug has been marked as a duplicate of 275783 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 5

14 years ago
Whoops, someone pointed out to me that this isn't exactly a dupe of 275783, my
apologies.

->Re-opening
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 6

14 years ago
Possible relation to bug 271574 or duplicate?

Comment 7

13 years ago
I use the latest JRE software (1.5.0 beta 4 build 05) with the latest Deer Park
alpha 1 rv: 1.8b2 build 20050626 a couple of hours on http://games.yahoo.com and
did not crash a single time. XP Pro SP 2 here.

Comment 8

13 years ago
On FireFox 1.0.6 with Tabbrowser, JRE software (1.5.0 beta 4 build 05), XP Pro
SP 1 here or XP Family SP2 at home, crash on graph with www.boursorama.com.
Crash after open 1 or 2 applet, close 1, the next one will freeze firefox. After
close firefox, still procces in task panel.

Comment 9

13 years ago
This bug also there is in Windows 2003 Server in Firefox 1.5 beta 2

Comment 10

13 years ago
> The crash occurs 
> when I am closing out a table, switching rooms, checking out player information
> or logging out.
 
> Actual Results:  
> It eventually crashed sometime in the course of being logged in and 
> playing yahoo dominoes.

I played many times dominoes at games.yahoo.com and never crashed while using the latest Firefox 1.5. I have been using Sun's JRE 1.5.0 build 1.5.0_05-b05.

> This problem has occured on three different computers all running 
> Windows XP PRO. One of the computes is a Pentium III 550 MZ:128mb ram

If you are running XP Pro on a PIII 550MHz with 128MB RAM, you will crash for sure because you will lack sufficient RAM to run java applets. You even lack sufficient RAM to use a lot of applications. 128MB is not recommended; 256MB is recommended for XP Pro.

> It does not give me a module in which the software crashed.

Without a talkback incident id, stack trace or anything, it is impossible to investigate the issue any further. Also, java classes are continuously being upgraded, tuned at games.yahoo.com: so the java application could/may crash and this will be reported in the java console. But here, you're mentioning that the *_browser application_* is crashing. So we first need talkback incident ID and crash data regarding a recent Firefox build.
Keywords: qawanted

Comment 11

13 years ago
dose not matter which site, jre2 dosen't work with any site that uses java. jre2 crashes browser on any attempted logon to any site containing java content. I can reproduce this bug on damand.

Comment 12

13 years ago
dose not matter which site, jre2 dosen't work with any site that uses java. jre2 crashes browser on any attempted logon to any site containing java content. I can reproduce this bug on damand.

Comment 13

13 years ago

*** This bug has been marked as a duplicate of 285390 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.