Closed Bug 287842 Opened 20 years ago Closed 20 years ago

blocked images are displayed as broken images

Categories

(Firefox :: General, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

()

VERIFIED FIXED

People

(Reporter: Peter6, Assigned: bugzilla)

References

Details

(Keywords: regression)

Attachments

(1 obsolete file)

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050326
Firefox/1.0+ 00:09 PST build

repro:
1. Open http://www.yahoo.com/
2. Rightclick on an image and choose "block images from ..."
3. Reload the page
4. Notice that the images are blocked ... but the red dot for broken image is
displayed.

this regressed between 20050325 14:18 PST and
20050326 00:09 PST

in the older build there is no missing image icon

CC -> bzbarsky
can you check if this is caused by Bug 285981 Boris ?
Summary: blocked images is displayed as broken image → blocked images are displayed as broken images
It seems that it was, but because we're using nsImgManager, not
nsContentBlocker... (at least in SeaMonkey).  I thought we'd flipped the switch
to use the latter.
Attached patch Fix at least SeaMonkey (obsolete) — Splinter Review
I don't have a working Firefox build at the moment (things are still building
from the pull I did on Friday), but this fixes SeaMonkey...
Attachment #178733 - Flags: superreview?(darin)
Attachment #178733 - Flags: review?(mvl)
actually removing nsImgManager is bug 287628. That would also fix this bug.
Er...  But if we're using nsImgManager, then there is no way to tell from the
content policy return value why the image was blocked, is there?  So should we
back out bug 202906?

Or are we saved by the fact that we no longer use the prefs that nsImgManager
looks at?
Depends on: 287628
nsImgManager will be removed. the new version, nsContentBlocker tries to return
the right values. No need to back out.
Comment on attachment 178733 [details] [diff] [review]
Fix at least SeaMonkey

this patch is now obsolete, bug 287628 was checked in
Attachment #178733 - Attachment is obsolete: true
Attachment #178733 - Flags: superreview?(darin)
Attachment #178733 - Flags: review?(mvl)
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050329
Firefox/1.0+ 02:52PST

patch bug 287628 included

->WFM

can this bug be resolved/wfm ?
When blocking images from a website, is the alt text meant to be shown instead
of the picture? Because currently it isn't, but iirc it used to do this.
that's bug 285981 which is supposed to be fixed.
I can confirm it isn't.
that bug is about security blocked images, like when linking to file:// images
from a http:// page.
Images that are blocke dusing the image manager don't show alt-text, becuase it
are usually ads, and you don't want to read alt either in that case. see bug 202906
Fixed by checkin for bug 287628.  To make it clear, the desired (and now
implemented behavior) is that alt text is shown for all images that are not
loaded with the single exception of images blocked via the "block images from
this site" option in image manager.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
->verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: