Need "expanded folder with new messages" and "account with new messages" icons

RESOLVED FIXED

Status

SeaMonkey
MailNews: Message Display
P3
normal
RESOLVED FIXED
18 years ago
13 years ago

People

(Reporter: Richard Zach, Assigned: gayatrib)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
The "biff icon" (the one with the green downward arrow), which marks a folder
with new messages in the folder pane, turns into a plain "open file folder" icon
if the folder has subfolders, and the subfolder tree is expanded.  It should
still have an icon with a green arrow when the folders are expanded.

To reproduce:
1. Open an IMAP accoutn on a cyrus server (where all the folders are subfolders
of Inbox).
2. Select Inbox
3. get new messages
4. Expand folder list

Actual result: Folder icon turns from "biff icon" to plain "open folder" icon.
Expected result: even when folder list expanded you should have visual
confirmation that new messages are waiting to be looked at.

Conversely, if an account has all folders hidden (just the account icon and
account name are visible), the account icon should get a green arrow if there
are new messages in the account's Inbox.

To reproduce:
1. Get new messages on your favorite Inbox, see biff icon on folder
2. Collapse folder list for that account

Actual result: plain account icon with twistie
Expected result: visual indication that account has new messages

Linux build 2000.02.21.08

Comment 1

18 years ago
Jennifer or Scott, do we need more icons for this, or do we have them and they 
just aren't hooked up?

Looks related to several other bugs on putterman's list, but I don't see any 
glaring dups.
Assignee: phil → putterman

Comment 2

18 years ago
Inbox with new messages icon is part of bug 25961:
http://gooey/client/5.0/specs/visuals/icons/icon_mail/beta1/mailsmall/inboxnew.g
if

Folder icons with green diamond do not exist yet.  I will talk to Shuang.

So we need one icon for the closed folder with new mail AND one icon with the 
open folder with new mail.

Comment 3

18 years ago
Inbox with new messages icon is part of bug 25961:
http://gooey/client/5.0/specs/visuals/icons/icon_mail/beta1/mailsmall/inboxnew.g
if

Folder icons with green diamond do not exist yet.  I will talk to Shuang.

So we need one icon for the closed folder with new mail AND one icon with the 
open folder with new mail.

Comment 4

18 years ago
I've been ignoring all of these icon bugs to work on other things.  But a bunch 
of these are getting filed all of a sudden.  Is this just because someone's 
noticing them or is this something we need for beta?

Comment 5

18 years ago
My mistake, there is no Account-new mail icon yet either.  Will let Shuang know.

Is this for B1 or later?

Comment 6

18 years ago
Post B1 is fine

Comment 7

18 years ago
Reassign to Shuang as a reminder:

So we need:
   icon for account with new mail (green diamond)
   icon for the closed folder with new mail (green diamond)
   icon with the open folder with new mail (green diamond)
Assignee: putterman → shuang

Updated

18 years ago
Assignee: shuang → putterman

Comment 8

18 years ago
These icons now available.  Reassign to Putterman.

Folder icon closed with new mail (green diamond):
http://gooey/client/5.0/specs/visuals/icons/icon_mail/beta1/mailsmall/folderclos
ednew.gif

Folder icon open with new mail (green diamond):
http://gooey/client/5.0/specs/visuals/icons/icon_mail/beta1/mailsmall/folderopen
new.gif

Mail Server with new mail icon (green diamond)
http://gooey/client/5.0/specs/visuals/icons/icon_mail/beta1/mailsmall/mailserver
new.gif

Comment 9

18 years ago
marking m17
Status: NEW → ASSIGNED
Target Milestone: --- → M17

Comment 10

18 years ago
Mail Review hopes this is post-beta2, easy, polish work.  Marking M18.
Target Milestone: M17 → M18

Comment 11

18 years ago
reassigning to gayatrib.  This sounds like a dup of a bunch of other bugs that
you currently have.
Assignee: putterman → gayatrib
Status: ASSIGNED → NEW

Updated

17 years ago
Target Milestone: M18 → ---

Comment 12

17 years ago
I think this can be marked fixed, the icons appear to be in the product.

Comment 13

17 years ago
Marking as fixed.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.