It is not possible to return it to "YOMI" with IME.(IME Keyboard short-cut ESC / Control+z doesn't work. )

RESOLVED FIXED

Status

--
major
RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: sugar.waffle, Assigned: sfraser_bugs)

Tracking

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

14 years ago
The character that has not been fixed with IME can be returned by pushing the
esc key based on a temporary conversion result etc.

For instance, it returns before it converts it by pushing the escape key, and
the input mistake can be corrected before Japanese conversion is still fixed. 

But in Camino, keyboard shot cutting ESC or Control+z, function of returned to
this "YOMI" doesn't work.
This is very annoyed in Japanese input to say nothing of the user experience. 

Of course, there is no problem in Firefox/Mozila Suite.
 
Reproducible: Always
Steps to Reproduce:
1.IME is turned on. 
2.The character is input to INPUT or TEXTAREA. 

3.push ESC key.
  Expected Results:The input character disappears all. 

4.Some characters are input again. 
5.push Space key.
  (A temporary conversion result is displayed. )
6.push ESC key.
  Expected Results:A temporary conversion result is canceled. 


Mac OS X 10.3.8
trunk nightly build 2005032619 (v0.8+)
(Reporter)

Comment 1

14 years ago
In build to 2005032408 (v0.8+), this problem is not. 
It reproduced with build of 2005032508 (v0.8+). 

Comment 2

14 years ago
Confirmed.
Is this connected with attachment 177217 [details] [diff] [review] landed in 2005-03-25?
(Reporter)

Comment 3

14 years ago
(In reply to comment #2)
> Is this connected with attachment 177217 [details] [diff] [review] [edit] landed in 2005-03-25?

The problem reproduces though this patch was done in reject and tried. 
(Assignee)

Comment 4

14 years ago
Sorry, it's not quite clear from that last comment: is this bug a regression
caused by bug 233288?
(Reporter)

Comment 5

14 years ago
(In reply to comment #4)
> Sorry, it's not quite clear from that last comment: is this bug a regression
> caused by bug 233288?
No.
I think that it is another cause. 
This problem reproduced though the patch of bug233288 was removed. 
(Assignee)

Comment 6

14 years ago
Perhaps bug 153836 broke this.

Comment 7

14 years ago
You are probably right. I should probably check to make sure the document is
still loading beofre using escape to stop the pageload, though this would mean
that escape wouldn't return the user to yomi while the page is loading. I could
just pass escape on no matter what, too, but I'm afraid that it will cause beep
if the user isn't in IME mode even if we do cause load-stop.

Comment 8

14 years ago
Actually, is there a method I can call to see if we're in the IME?

Comment 9

14 years ago
Created attachment 178929 [details] [diff] [review]
rough patch : Check whether IME is now used or not.

Please check my patch carefully whether this patch cause another bug or not....

Comment 10

14 years ago
It would probably work if we used native text fields in the browser area, but we
don't (so AFAICT we're not using Cocoa's text input stuff). If so, that patch
probably won't work (but someone should verify that my assumption is correct).

Comment 11

14 years ago
Actually, you might still be right; someone should test this.

Comment 12

14 years ago
The only problem I can see now (providing this works) is that the IME check
should only occur if we're not in the URL field.
(Reporter)

Comment 13

14 years ago
(In reply to comment #12)
> The only problem I can see now (providing this works) is that the IME check
> should only occur if we're not in the URL field.
The input of Japanese etc. that uses IME for the URL field like IDN or key word
search, etc. might be done. 
Therefore, I think that it should check the status of IME in all places. 

Comment 14

14 years ago
(In reply to comment #13)
> (In reply to comment #12)
> > The only problem I can see now (providing this works) is that the IME check
> > should only occur if we're not in the URL field.
> The input of Japanese etc. that uses IME for the URL field like IDN or key word
> search, etc. might be done. 
> Therefore, I think that it should check the status of IME in all places. 

Then it still needs to be moved around a bit so that the URL field isn't erased
if IME is currently active when escape is pressed.
(Reporter)

Comment 15

14 years ago
The escape key has not worked yet by the IME input of TEXTAREA/INPUT. 
This is fatal. 

Because the source was changed, this patch cannot be applied. 
https://bugzilla.mozilla.org/attachment.cgi?id=178929
(Assignee)

Updated

14 years ago
Assignee: pinkerton → sfraser_bugs

Comment 16

14 years ago
Created attachment 188768 [details] [diff] [review]
I rewrite : more simple.
Attachment #178929 - Attachment is obsolete: true
(Assignee)

Comment 17

14 years ago
Checked in. Thanks for the patch!
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.