Mozilla crashes when trying to forward/inline a certain msg in a Local folder

RESOLVED FIXED in M14

Status

MailNews Core
MIME
P3
normal
RESOLVED FIXED
18 years ago
9 years ago

People

(Reporter: Katsuhiko Momoi, Assigned: Jean-Francois Ducarroz)

Tracking

({crash})

Trunk
x86
Windows NT
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
** Observed with 2/21/2000 Win32 build **

This bug came out of trying to verify Bug 23931. 

Here's how to reproduce this crashing bug:

1. I have the Intl Smoketest folder on an IMAP server.
2. Display the 3rd msg -- this is a Japanese msg with Netscape
   Japan Home Page eatatched.
3. Create a new folder in the Local Mail directory, and copy the 
   IMAP msg in step 2 into this new sub folder.
4. Now display this same message in the Local folder.
5. Try to engage Message | Forward as inline.
   This is when it crashes Mozilla. This does not seem to be
   a brand new problem and it occurs as far as 2/10/00 Win32 build
   but it does not occur with M13-RTM build (1/25/00).

Here's the crash report I sent to Talkback:

http://cyclone/reports/incidenttemplate.CFM?reportID=124&style=0&tc=37&cp=1&ck1
=SUser+email+address&cd1=%25momoi%40netscape%2Ecom%25&co1=like&bbid=5720685

--------------------------

Trigger Type:  Program Crash 
Trigger Reason:  Access violation 
Thread ID: 227

Call Stack:    (Signature = nsStreamConverter::GetIdentity fe99f2c0) 
nsStreamConverter::GetIdentity 
[d:\builds\seamonkey\mozilla\mailnews\mime\src\nsStreamConverter.cpp, line 626]
mime_bridge_create_draft_stream 
[d:\builds\seamonkey\mozilla\mailnews\mime\src\mimedrft.cpp, line 1813]
 bridge_create_stream 
[d:\builds\seamonkey\mozilla\mailnews\mime\src\nsStreamConverter.cpp, line 82]
nsStreamConverter::Init  
[d:\builds\seamonkey\mozilla\mailnews\mime\src\nsStreamConverter.cpp, line 533]
nsStreamConverter::AsyncConvertData  
[d:\builds\seamonkey\mozilla\mailnews\mime\src\nsStreamConverter.cpp, line 847]
nsMsgDraft::ProcessDraftOrTemplateOperation 
[d:\builds\seamonkey\mozilla\mailnews\compose\src\nsMsgCreate.cpp, line 209]
nsMsgDraft::OpenDraftMsg  
[d:\builds\seamonkey\mozilla\mailnews\compose\src\nsMsgCreate.cpp, line 251]
nsMsgComposeService::OpenComposeWindow  
[d:\builds\seamonkey\mozilla\mailnews\compose\src\nsMsgComposeService.cpp, line 
123]
XPTC_InvokeByIndex 
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcinvoke.cpp, 
line 139]
nsXPCWrappedNativeClass::CallWrappedMethod 
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativeclass.cpp, 
line 899]
WrappedNative_CallMethod 
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativejsops.cpp, 
line 195]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 666]
js_Interpret  [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2293]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 682]
js_Interpret [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2293]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 682]
js_Interpret  [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2293]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 682]
js_InternalInvoke  [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 755]
JS_CallFunctionValue [d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 2789]
nsJSContext::CallEventHandler  
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp, line 566]
nsJSEventListener::HandleEvent  
[d:\builds\seamonkey\mozilla\dom\src\events\nsJSEventListener.cpp, line 129]
nsEventListenerManager::HandleEventSubType  
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventListenerManager.cpp, line 
700]
nsEventListenerManager::HandleEvent 
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventListenerManager.cpp, line 
1463]
nsXULElement::HandleDOMEvent 
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 2978]
nsMenuFrame::Execute 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsMenuFrame.cpp, line 1121]
nsMenuFrame::HandleEvent 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsMenuFrame.cpp, line 285]
PresShell::HandleEvent  
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 2954]
nsView::HandleEvent  [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 
799]nsView::HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 
784]
nsViewManager2::DispatchEvent  
[d:\builds\seamonkey\mozilla\view\src\nsViewManager2.cpp, line 1216]
HandleEvent  [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 69]
nsWindow::DispatchEvent 
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 497]
nsWindow::DispatchWindowEvent 
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 514]
nsWindow::DispatchMouseEvent 
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 2940]
ChildWindow::DispatchMouseEvent  
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3156]
nsWindow::ProcessMessage 
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 2257]
nsWindow::WindowProc 
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 672]
USER32.dll + 0x1186 (0x77e41186)

--------------------------

Comment 1

18 years ago
Looks like a forwarding issue?

- rhp
Assignee: rhp → ducarroz
(Reporter)

Comment 2

18 years ago
I should mention that if you forward/inline the message which is on the IMAP server,
then it works and Mozilla does NOT crash. It is only when you copy that same message
to a Local folder and try forward/inline that it crashes,
I added "Local Folder" to the summary line.
Summary: Mozilla crashes when trying to forward/inline a certain msg → Mozilla crashes when trying to forward/inline a certain msg in a Local folder
(Assignee)

Comment 3

18 years ago
oh, it's the same crash than bug 28349 that I fixed recently.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
Target Milestone: M14

Comment 4

18 years ago
Adding crash keyword
Keywords: crash

Updated

17 years ago
QA Contact: lchiang → momoi

Comment 5

17 years ago
Kat, does it still happen to you? i can not reproduce it with 2001-07-11 build
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.