Closed Bug 287915 Opened 15 years ago Closed 11 years ago

After moving profile directory, I am unable to load TB

Categories

(MailNews Core :: Backend, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 196119

People

(Reporter: glen.oriley, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

I have moved my profile (emails) to another partition for backup purposes. I
followed the info I received off the help pages. Now, whenever I load TB, I just
get a blank tb screen with folders in the top left and it freezes. I can only
load it in safe mode and cannot get my news groups to work.

I find this program good except for this, hopefully this won't stop it.

Reproducible: Always

Steps to Reproduce:
1.Copy profile to different partition
2.Update profiles info file
3.Attempt to load TB

Actual Results:  
TB freezes

Expected Results:  
Loaded up and displayed my emails
have you read
http://kb.mozillazine.org/Thunderbird_:_FAQs_:_Changing_Profile_Folder_Location
especially the part: "Still not working?" ?

please post your C:\Documents and Settings\WindowsUserAccountName\Application
Data\Thunderbird\profiles.ini
I just ran into the same problem. When one follows the instructions found at
<http://www.mozilla.org/support/thunderbird/profile>, it just says to move the
directory elsewhere and to edit the profiles.ini.

However, those instructions forget to mention one critical thing, namely that
the path you put in there *must* use backslashes.

Say your original profile entry contains something like

IsRelative=1
Path=Profiles/anec37w6.default

If you change that to 

IsRelative=0
Path=D:/myprofile

TB will not accept it: the modified profile will actually be removed from
profiles.ini. If that happened to be your only profile, TB will behave as if it
is a new installation.

The modification does work when backslashes are used, like

IsRelative=0
Path=D:\myprofile

The confusion is caused by the fact that the default relative paths use forward
slashes where the absolute paths only work when they use back slashes.

A way out is to use the profile manager to create a new profile, and to select
your new profile directory as the place you want to store the profile data.
TB will pick up the profile you already copied in there (at least it did so for
me, with TB 1.5beta1).

I don't know if the reporter made the mistake of using forward slashes but it
would explain the problem.

Please update the instructions on the web site to include this point (and
provide a working example?)
I had a similar problem, the folders were not visible, the file and edit menu
buttons were not visible but the menu was displayed etc. but after uninstalling
all extensions, the problem is rectified. 
Raj Iyer (rajan.v.iyer@gmail.com)
TB: 1.0.7.de, WinXP, happens always, already with older versions
I have this kind of Problem as well, when I use path
'D:\Mozilla\Thunderbird\3j9qqeeu.default', whereas when using
'D:\Thunderbird\3j9qqeeu.default' TB starts up and synchronises as required. 

Error indication:
The folder list of the mail accounts (multiple) is empty, but I can still go
into accounts and see my accounts and some of the menu strings (e.g. Datei/File)
are missing as well. Mail retrival does not work then. 
Sending mail I have not tried, but don't expect it to work anyway.

profile.ini:
[General]
StartWithLastProfile=1

[Profile0]
Name=default
IsRelative=0
Path=D:\[Mozilla\]Thunderbird\3j9qqeeu.default /* with 'Mozilla\' in it it will
not work! */ 
QA Contact: migration
If I understand the comments correctly, this bug is essentially the bug about using relative pathnames in panacea.dat, the number of which escapes me.

Until I (or someone else) can remember the bug number, moving to correct component and adding dupeme...
Assignee: mscott → nobody
Component: Migration → MailNews: Backend
Product: Thunderbird → Core
QA Contact: migration → backend
Whiteboard: dupeme
Product: Core → MailNews Core
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 196119
Cleanup *dupeme* whiteboard flag from bugs that are marked as Resolved Duplicate!
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.