[nightly] Crash on inital startup (dies and won't rise agian)

RESOLVED FIXED

Status

()

--
blocker
RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: mozillamonks, Assigned: bugzilla)

Tracking

({qawanted, smoketest})

Trunk
x86
Windows XP
qawanted, smoketest
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
When running the latest nightly on a dual Pentium IV system with Windows XP Pro
SP2 (with a previous installation of Firefox 1.0.1 that was /not/ removed before
install.) two error messages appear on first start, the program remains in
memory and future trys to access the program fail silently.

Steps to Reproduce:
1. Download the March 27, 05 nightly build
2. Run the installer
3. Watch the crash on first start.

The attached screenshot shows the error messages which are:
"The procedure entry point ?Equals@nsCSubstring@@QBEHABV1@@Z could not be
located in the dynamic link library xpcom.dll." and
"The procedure entry point PL_DHashTableFinish could not be located in the
dynamic link library xpcom.dll."

Talkback won't catch the error, so it's impossible to track the exact point of
disaster....
I'm going to try this on other system in the next few min. as well.
(Reporter)

Comment 1

14 years ago
Created attachment 178749 [details]
Screenshot of error messages (cropped for easier viewing)
(Reporter)

Comment 2

14 years ago
I verified this again on the same PC (as a note this is a remote install via
windows Remote Connection feature.)

This time, the browser actualy loaded after the bug.  There error occurs on each
instance start.

This also occurs on a fresh install.

(Reporter)

Comment 3

14 years ago
This also occurs on another single-processor WinXPSP2 system on a local install.

Overwriting the install with 1.0.1 will allow it to work OK agian.

Comment 4

14 years ago
In the March 28, 05 nightly this bug doesn't seem to be replicated following
your steps.  Running similar platform with XPSP2.
(Reporter)

Comment 5

14 years ago
This still happens with April 3rd's build.
(Reporter)

Comment 6

14 years ago
Seems to be FIXED in latest nightlies.  Probably a profile issue.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.