Closed Bug 287956 Opened 19 years ago Closed 19 years ago

Crash shortly after program start [@nsProtocolProxyService::PruneProxyInfo]

Categories

(Core :: Networking, defect, P1)

x86
Linux
defect

Tracking

()

RESOLVED FIXED
mozilla1.8beta2

People

(Reporter: jmccabe, Assigned: darin.moz)

References

Details

(Keywords: crash, regression)

Crash Data

Attachments

(3 files)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2) Gecko/20050326
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2) Gecko/20050326

Immediately following startup Thunderbird begins checking for new mail and
performaing virus scan. Within thirty seconds the program throws core with a
Signal 11.

Reproducible: Always

Steps to Reproduce:




Stack trace coming.

Looks like this is happening in libnecko.so.
Attached file Stack trace
http://lxr.mozilla.org/seamonkey/source/netwerk/base/src/nsProtocolProxyService.cpp#1320
1323         for (nsProxyInfo *iter = head; iter; iter = iter->mNext, last = iter) {
1324             if (iter->Type() == kProxyType_HTTP) {
1325                 // reject!
1326                 if (last)
1327                     last->mNext = iter->mNext;
1328                 else
1329                     head = iter->mNext;
1330                 iter->mNext = nsnull;
1331                 NS_RELEASE(iter);
1332             }
1333         }

So, this NS_RELEASE will set iter to null, and that will make the for loop
dereference a null pointer... something's not quite right here...

I think this code wants to continue the loop with iter pointing to what used to
be iter->mNext.
Assignee: mscott → darin
Status: UNCONFIRMED → NEW
Component: General → Networking
Ever confirmed: true
Keywords: crash, regression
Product: Thunderbird → Core
QA Contact: benc
Version: unspecified → Trunk
seems to me like this loop should look more like the other loop in this function.

caused by bug 282442
*** Bug 288037 has been marked as a duplicate of this bug. ***
Summary: Crash shortly after program start → Crash shortly after program start [@nsProtocolProxyService::PruneProxyInfo]
I'm working on a patch.
Status: NEW → ASSIGNED
Priority: -- → P1
Target Milestone: --- → mozilla1.8beta2
Attached patch v1 patchSplinter Review
Attachment #178830 - Flags: review?(cbiesinger)
Attachment #178830 - Flags: review?(cbiesinger) → review+
fixed-on-trunk
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
Crash Signature: [@nsProtocolProxyService::PruneProxyInfo]
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: