Uploading an identical addon version shouldn't be allowed

RESOLVED FIXED

Status

addons.mozilla.org Graveyard
Developer Pages
--
major
RESOLVED FIXED
13 years ago
2 years ago

People

(Reporter: alanjstr, Assigned: morgamic)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
If you upload version 0.5, and then come back later and upload 0.5 again, it
overwrites without giving you a chance to cancel.  This means that you have to
go through the approval process again even if you didn't need to.

"Warning! A version Record already exists for this item's Application/OS/Version
combination. Deleting."
(Reporter)

Updated

13 years ago
Summary: Updating the same version overides without prompting → [Submission] Updating the same version overides without prompting
(Assignee)

Updated

12 years ago
Assignee: Bugzilla-alanjstrBugs → morgamic
Severity: normal → major
Summary: [Submission] Updating the same version overides without prompting → Uploading an identical addon version deletes existing, shouldn't be allowed
Target Milestone: 1.0 → 2.1
(Reporter)

Comment 1

12 years ago
Why shouldn't it be allowed?  Say someone has version 1.0, and they want to add applications to the install.rdf.  That doesn't warrant everyone else to upgrade to 1.0.1.
(Assignee)

Comment 2

12 years ago
Doesn't that defeat the whole point of versioning?

Also, if their extension worked for an app, they should place it in the install.rdf the first time.
(Assignee)

Comment 3

12 years ago
Also, they can always just edit the metadata after-the-fact, but not edit the actual .xpi.
(Reporter)

Comment 4

12 years ago
(In reply to comment #3)
> Also, they can always just edit the metadata after-the-fact, but not edit the
> actual .xpi.

You can modify the compat range, but can you add an app?

(In reply to comment #2)
> Doesn't that defeat the whole point of versioning?

Its the same version

> Also, if their extension worked for an app, they should place it in the
> install.rdf the first time.

What if Netscape releases v10 based on Firefox 1.5?  Or you didn't test it with Seamonkey but it works with it.
(Assignee)

Comment 5

12 years ago
Okay, I guess it's useful to replace it, but it should probably be restricted (maybe) and definitely does require a prompt (we agree on that).
Summary: Uploading an identical addon version deletes existing, shouldn't be allowed → Uploading an identical addon version deletes existing without a prompt

Updated

12 years ago
Version: 1.0 → 2.0
If there are specific use cases for changing what a version applies to, then let's talk about those in another bug, when they become a problem.  The current behaviour is very much a problem today, in the vast majority of the cases "silent respins" are something we really want to avoid, and we have other options for permuting install.rdf than allowing a full upload.

When you file that other bug, please cc: extension authors who have had to do re-uploads in order to add new application compatibility information.  Or, I suppose, *wanted* to, because you can't actually upload a new copy of the version without screwing yourself...

And if we indeed don't check the metadata for applications (as we do for versions), please file that bug as well, against the EM.
It's *not* the same version, in terms of having the same user experience.  Changing install.rdf can break things, and not being able to distinguish between the broken and working cases is bad bad bad.

Other bugs for specific update-in-place use cases; if we want to permit them at all (they can upload another version that is only for the new applications, can they not, to avoid all their users updating?), and we can't solve them on the client side with metadata refreshing (possibly fixed in Fx2), then we should address them minimally, not by leaving this sharp tool lying around.

morgamic: I think you should unmorph this bug.
*** Bug 321314 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

12 years ago
Summary: Uploading an identical addon version deletes existing without a prompt → Uploading an identical addon version deletes existing, shouldn't be allowed

Comment 9

12 years ago
It seems that somewhere along the line (possibly since the patch to sort by vID?) this bug has changed. Milx informs me that after uploading a new addon with the same version, the old one wasn't deleted, and once the new one was approved, the website continued to serve the OLD version. I can't verify this (milx may have been getting a cached page or whatever.)

Anyway, adjusting bug summary to reflect this. Below is the IRC log.


[15/05/2006 1:49 AM] <Milx> what will happen if I submit the same version of extension?
[15/05/2006 1:50 AM] <_RSZ_> try it and you may found a bug about update :-D
[15/05/2006 1:51 AM] <Milx> I tried and it said "Pending Approval"
[15/05/2006 1:52 AM] <Milx> But the original one is still there

--

[15/05/2006 6:42 PM] <Milx> I submited the same version of extension and waited for its approval
[15/05/2006 6:42 PM] <Cameron|afk> Milx: that might be a bad idea
[15/05/2006 6:42 PM] <Cameron> not sure though
[15/05/2006 6:42 PM] <Milx> but
[15/05/2006 6:42 PM] <Cameron> in the past it has sometimes deleted the old version :s
[15/05/2006 6:42 PM] <Milx> i done
[15/05/2006 6:42 PM] <Cameron> what's the name of your extension?
[15/05/2006 6:42 PM] <Milx> and the old one still there
[15/05/2006 6:43 PM] <Cameron> oic, maybe the bug was dived
[15/05/2006 6:43 PM] <Cameron> *fixed
[15/05/2006 6:43 PM] <Milx> Search Engine Wizard
[15/05/2006 6:44 PM] <Milx> I want the new one on the website
[15/05/2006 6:44 PM] <Milx> how can I do?
[15/05/2006 6:44 PM] <Cameron> Milx: wait for someone to review it :) = patience
[15/05/2006 6:44 PM] <Milx> the new one with same version
[15/05/2006 6:46 PM] <Cameron> bug 287977 is the one I was talking about
[15/05/2006 6:46 PM] <firebot> Cameron: Bug https://bugzilla.mozilla.org/show_bug.cgi?id=287977 maj, --, 2.1, morgamic@gmail.com, NEW, Uploading an identical addon version deletes existing, shouldn't be allowed
[15/05/2006 6:47 PM] <Milx> so I need to delete it first
[15/05/2006 6:47 PM] <Milx> and submit the new one?
[15/05/2006 6:48 PM] <Cameron> nono, I'm not sure
[15/05/2006 6:48 PM] <Cameron> why didn't you increment the version in the first place?
[15/05/2006 6:50 PM] <Cameron> milx.. hasn't your new version been approved anyway?
[15/05/2006 6:50 PM] <Milx> because the one with newer version means it has new functions
[15/05/2006 6:51 PM] <Milx> my new version has been approved
[15/05/2006 6:51 PM] <Milx> but I delete it just now
[15/05/2006 6:52 PM] <Cameron> oic.. you were trying to patch an old version?
[15/05/2006 6:52 PM] <Milx> can your check my new one now?
[15/05/2006 6:54 PM] <Cameron> Milx: you want to change the version to 0.2.2.4
[15/05/2006 6:55 PM] <Cameron> actually hang on
[15/05/2006 6:55 PM] <Milx> I need change the version to 0.2.2.4?????
[15/05/2006 6:55 PM] <Cameron> nono my bad
[15/05/2006 6:55 PM] |<-- Mossop has left irc.mozilla.org:6697 (Quit: Fleeing the scene...)
[15/05/2006 6:56 PM] <Cameron> ok.. so you submitted 0.2.2.1, and it was approved.. then you noticed a bug in 0.2.2.1 so you resubmitted 0.2.2.1 again, and that was approved too - but what version did the website serve?
[15/05/2006 6:57 PM] <Milx> 0.2.2.1
[15/05/2006 6:57 PM] <Cameron> yeah but was it the old 0.2.2.1 or the new 0.2.2.1?
[15/05/2006 6:57 PM] <Milx> but the old 0.2.2.1
[15/05/2006 6:57 PM] <Cameron> I see
[15/05/2006 6:57 PM] <Milx> and now
[15/05/2006 6:57 PM] <Milx> I delete it
[15/05/2006 6:58 PM] <Milx> and resubmit
[15/05/2006 6:58 PM] <Cameron> I see
[15/05/2006 6:58 PM] |<-- iosart has left irc.mozilla.org:6697 (Connection reset by peer)
[15/05/2006 6:58 PM] <Milx> and is this cause error?
[15/05/2006 6:59 PM] <Cameron> the problem with that idea, is that firefox will check for updates and see that it's still got the same version, but that it's different.. and that might cause problems :s I sincerely suggest you increment the version number to 0.2.2.2 (or 0.2.2.1.1)
[15/05/2006 6:59 PM] <Milx> ok
[15/05/2006 7:00 PM] <Cameron> sorry I can't offer any more help right now. If you have further questions, ask them and possibly someone else will get back to you, or I will be back in an hour or two or so, or you can leave your email and I can try to get back to you that way
[15/05/2006 7:02 PM] <Milx> thank you
[15/05/2006 7:07 PM] <Mook> so, what should I give for branches? :p (two XPIs of the same extension, one for aviary one for 1.8/trunk, same version number... ) :p
[15/05/2006 7:11 PM] <Mossop> Mook: Would be nice, but Im pretty sure thats not possible
[15/05/2006 7:11 PM] <Mook> yeah :p
[15/05/2006 7:11 PM] <Mook> maybe I just need to drop aviary... :)
[15/05/2006 7:12 PM] <Mossop> Meh, Im thinking of dropping support for 2.0 ;)
Summary: Uploading an identical addon version deletes existing, shouldn't be allowed → Uploading an identical addon version does nothing, shouldn't be allowed
(Assignee)

Comment 10

12 years ago
I agree with Shaver's comments (as per comment #2) -- I think that allowing users to upload new .xpi's for the same version is not a good idea and is contrary to the concept of versioning.

Uploads containing identical versions will no longer be allowed.  An author can always upload a new .xpi with an updated install.rdf if they want to add a new application (and continue to use the dev cp for updating app verions).

This will ensure consistency with the idea behind versioning and avoid problems with overwritten .xpi's not being available, etc.
Status: NEW → ASSIGNED
Summary: Uploading an identical addon version does nothing, shouldn't be allowed → Uploading an identical addon version shouldn't be allowed

Comment 11

12 years ago
AMO bugspam. Correcting QA contacts on OLD bugs (mozilla.update@update.bugs)

-> Correct QA contact (developers@add-ons.bugs)

Filtermeplzkthx
QA Contact: mozilla.update → developers
(Assignee)

Comment 12

12 years ago
Created attachment 227269 [details] [diff] [review]
Patch to reject any identical versions.

This should disallow the uploading of .xpi's that are submitted that contain versions identical to something that already exists.
Attachment #227269 - Flags: first-review?(shaver)
Comment on attachment 227269 [details] [diff] [review]
Patch to reject any identical versions.

r=shaver, yay. morgamic: can we sneak this out while you're working on the Great Admin Repair, to keep me from crying so much?
Attachment #227269 - Flags: first-review?(shaver) → first-review+
(Assignee)

Comment 14

12 years ago
Yessir, that's the plan.  :)
(Assignee)

Comment 15

12 years ago
This is checked -- will be updated in next batch, before the middle of the week.
(Assignee)

Updated

12 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Target Milestone: 2.1 → ---
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.