If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Get rid of view source window and display source in a browser window

RESOLVED DUPLICATE of bug 262915

Status

()

Toolkit
View Source
--
enhancement
RESOLVED DUPLICATE of bug 262915
13 years ago
9 years ago

People

(Reporter: Timwi, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2 StumbleUpon/1.9993
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2 StumbleUpon/1.9993

The "View Source" window is quite buggy and has all sorts of problems, most
notably that it turns "caret mode" on unexpectedly. But the biggest problem I
have with it is that it is always a separate window even though I prefer to have
all Firefox "pages" in one window (using tabs).

Hence, my suggestion would be to:

* allow URLs like sourceof:http://www.example.com/
* all this needs to do is display the same file, but pretend its content type
  were text/plain
* have the "View Source" command (Ctrl+U) switch to this URL within the same
  window/tab
* have a new command, "View Source in new Tab" (Ctrl+Shift+U)
* make the "Wrap long lines" command from the View Source window available to
  any window that is displaying text/plain (this would be an added benefit: I
  have often wished this option existed when I was actually viewing a text file
  and not HTML source).

Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

13 years ago
Of course, alternatively one could have a content-type like text/html-source or
something which will trigger syntax highlighting.

Comment 2

13 years ago
You can use an extension: http://www1.cs.columbia.edu/~mjg2101/ts/

Your number five is a separate issue.

Comment 3

13 years ago

*** This bug has been marked as a duplicate of 262915 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.