Diff view of (cvs diff) Attachments: some lines can be missing, and/or URL wrong

VERIFIED DUPLICATE of bug 233695

Status

()

Bugzilla
Attachments & Requests
VERIFIED DUPLICATE of bug 233695
13 years ago
11 years ago

People

(Reporter: sgautherie, Assigned: John Keiser (jkeiser))

Tracking

2.19.1
x86
Windows 2000
Bug Flags:
blocking2.20 -

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
I saw it twice today, on b.m.o..

Second time is:

https://bugzilla.mozilla.org/attachment.cgi?id=178811
{{
++  content/global/bindings/tree.xml            (widgets/tree.xml)
}}
is missing from
https://bugzilla.mozilla.org/attachment.cgi?id=178811&action=diff

Then requesting 'Raw Unified' has the same bug.
(Reporter)

Comment 1

13 years ago
First time was:

https://bugzilla.mozilla.org/attachment.cgi?id=156373&action=diff
which misses
{{
--- mozilla/mailnews/base/search/resources/locale/en-US/filter.properties	28 Feb
2003 00:21:23 -0000	1.16
+++ mozilla/mailnews/base/search/resources/locale/en-US/filter.properties	17 Aug
2004 21:13:29 -0000
}}
from
https://bugzilla.mozilla.org/attachment.cgi?id=156373

Then requesting 'Raw Unified' has the same bug.

Comment 2

13 years ago
Wow. This seems to be two different bugs; comment 0 refers to a line that starts
with a plus being missing in the diff. Comment 1 refers to a patch missing a
whole hunk from it. 
(Reporter)

Comment 3

13 years ago
[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.8) Gecko/20050511] (release) (W98SE)
[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b2) Gecko/20050701] (nightly) (W98SE)

Another issue: 'moz' is (now !?) added at the beginning of the filenames...

{{ <https://bugzilla.mozilla.org/attachment.cgi?id=178811&action=diff>

(+) mozmozilla/toolkit/content/jar.mn  (-1 lines)
(+) mozmozilla/toolkit/content/widgets/tree.xml  (-8 / +3 lines)
}}

Or could this one be a "new wanted feature" !??
(Reporter)

Updated

13 years ago
Flags: blocking2.20?
(Reporter)

Comment 4

13 years ago
(In reply to comment #3)
> (+) mozmozilla/toolkit/content/jar.mn  (-1 lines)

[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b3) Gecko/20050710 SeaMonkey/1.0a]
(nightly) (W98SE)

Or on the filename:
{{ <https://bugzilla.mozilla.org/attachment.cgi?id=175059&action=diff>
(+) mozilla/xpinstall/wizard/windows/setup/diadialogs.c  (-16 / +32 lines)
}}
(Reporter)

Comment 5

13 years ago
(In reply to comment #4)

[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b3) Gecko/20050710 SeaMonkey/1.0a]
(nightly) (W98SE)

Or in-between:
{{ <https://bugzilla.mozilla.org/attachment.cgi?id=152585&action=diff>
(+) mozilla/xpinstall/packager/winwin_mfcembed/config.it  (-1 / +1 lines)
+) mozilla/xpinstall/packager/winwindows/config.it  (-1 / +1 lines)
}}

Sigh :-(

Comment 6

13 years ago
This is irritating, certainly ('ve seen it happen), but not a release blocker.
Flags: blocking2.20? → blocking2.20-
(Reporter)

Comment 7

13 years ago
(In reply to comment #6)
> This is irritating, certainly ('ve seen it happen), but not a release blocker.

Additional bad behaviour example related to the link part:

[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b3) Gecko/20050714 SeaMonkey/1.0a]
(nightly) (W98SE)

https://bugzilla.mozilla.org/attachment.cgi?id=152140&action=diff
displays as
(-) mozmozilla/mailnews/addrbook/resources/content/addressbook.js  (-4 / +8 lines)
and links to
http://lxr.mozilla.org/mozilla/source/la/mailnews/addrbook/resources/content/addressbook.js
which obviously lead to a
"This file does not exist."


I guess this bug is a regression, but I can't verify it since I use b.m.o. site
only.
Even if it's not a "core" (database, ...) feature, it's seems useful enough to
be a blocker; but that's only my thought...
Summary: Diff view of (cvs diff) Attachments: some lines can be missing → Diff view of (cvs diff) Attachments: some lines can be missing, and/or URL wrong
(Reporter)

Comment 9

13 years ago
(In reply to comment #8)
> Created an attachment (id=190249) [edit]
> patch for PatchReader/Raw.pm that fixes problem
> 
https://bugzilla.mozilla.org/attachment.cgi?id=187534&action=diff&headers=1&context=file
https://bugzilla.mozilla.org/attachment.cgi?id=187534&action=diff&headers=1&context=file
https://bugzilla.mozilla.org/attachment.cgi?action=diff&id=187534&collapsed=&headers=1&context=30
> 
https://bugzilla.mozilla.org/test/attachment.cgi?id=187534&action=diff&headers=1&context=file
https://bugzilla.mozilla.org/test/attachment.cgi?id=187534&action=diff&headers=1&context=file
https://bugzilla.mozilla.org/test/attachment.cgi?action=diff&id=187534&collapsed=&headers=1&context=30

(You might want to check in both list why your 2 first URLs are identical...)

Anyway,
I tested comment 0 example:
Using the '/test/' URL fixes the issue on the filename links :-)
(Should review be asked for this patch !?)

Then, we need another patch for the content issue.

Updated

13 years ago
Attachment #190249 - Flags: review?

Updated

12 years ago
Assignee: attach-and-request → gerv
John Keiser maintains Patch Reader; this bug needs to be assigned to him, really.

Gerv
Assignee: gerv → john

Comment 11

12 years ago
Comment on attachment 190249 [details] [diff] [review]
patch for PatchReader/Raw.pm that fixes problem

This patch affects PatchReader/Raw.pm which is not part of the Bugzilla code. This has nothing to do with us and requesting review doesn't make sense. See gerv's previous comment.
Attachment #190249 - Flags: review?

Comment 12

12 years ago
Is this a dupe of bug 233695?
(Reporter)

Comment 13

12 years ago
Let's see:

Comment 0: Looks much like bug 233695.
Comment 1: Might be bug 233695 too !?

Comment 3: WorksForMe now.
Comment 4: WorksForMe now.
Comment 5: WorksForMe now.
Comment 7: WorksForMe now.

(Comment 8 'test' links are '404 Not Found' now.)

Still very much interested in a solution, whether we patch the tool, or use a version that works ... after (one, no:) two years :-/
Depends on: 233695
(Reporter)

Updated

12 years ago
Depends on: 303683
(Reporter)

Updated

12 years ago
Depends on: 365383
Duplicate of this bug: 365383
No longer depends on: 365383
(Reporter)

Comment 15

12 years ago
(In reply to comment #14)
> *** Bug 365383 has been marked as a duplicate of this bug. ***

Quote from that bug:
{
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.2pre) Gecko/20061229
SeaMonkey/1.1] (nightly) (W2Ksp4)

"Bugzilla was upgraded on December 26th at 6pm PST (2am Wednesday
UTC)." regressed comment 7.
}

Changing W98 to W2K, as I am currently dropping my old W98SE.
Depends on: 365063
OS: Windows 98 → Windows 2000
(Reporter)

Updated

12 years ago
Blocks: 365063
No longer depends on: 365063

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 233695

Updated

11 years ago
No longer depends on: 233695

Updated

11 years ago
No longer depends on: 303683
(Reporter)

Comment 17

11 years ago
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a3pre) Gecko/20070306 SeaMonkey/1.5a] (nightly) (W2Ksp4)

For the record,
my comment 13 stands, with current b.m.o BugZilla version, whatever it is.

***

I could have thought there was more data/discussion/work done here than there
...
but, all right, let's V.Duplicate.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 18

11 years ago
(In reply to comment #15)
> (In reply to comment #14)
> > *** Bug 365383 has been marked as a duplicate of this bug. ***
> 
> "Bugzilla was upgraded on December 26th at 6pm PST (2am Wednesday
> UTC)." regressed comment 7.

To be explicit, I noted there that that (temporary) regression is now WFM:
comment 13 stands as it was written.
You need to log in before you can comment on or make changes to this bug.