javascript variable 'location' causes page to infinitely reload/refresh

VERIFIED DUPLICATE of bug 131212

Status

SeaMonkey
General
--
minor
VERIFIED DUPLICATE of bug 131212
13 years ago
13 years ago

People

(Reporter: Greg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
Build Identifier: Mozilla/5.0

Found that a page created by another source had created a javascript variable 
named "location".  The page would infinitely reload, but would not crash the 
browser.  I was able to stop the reloading, but this filled up the server with 
a lot of GET requests.  I also found that by alerting the variable gave the url 
string, not the variable's string, in this case an empty string.  Changing the 
variable name fixed the problem, but location isn't a javascript reserved word 
and shouldn't cause this type of problem when being used as a varable.

Saw the problem in Firefox 1.0.2 and Netscape 7.2.  Could not reproduce the 
error in Internet Explorer or Netscape 7 and below.


Reproducible: Always

Steps to Reproduce:
1.Firefox 1.0.2 or Netscape 7.2 on an Apache Server
2.Create an html page with a javascript variable named location (var location 
= "";)
3.View page

Actual Results:  
Page kept reloading.

Expected Results:  
Page should completely load once.
(Reporter)

Comment 1

13 years ago
Sorry.. found that this was a duplicate of bug 131212 and is marked as WONTFIX.

*** This bug has been marked as a duplicate of 131212 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

13 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.