simple boolean checking of get_index_def's return value is error-prone

RESOLVED FIXED in Bugzilla 2.20

Status

()

RESOLVED FIXED
14 years ago
13 years ago

People

(Reporter: myk, Assigned: mkanat)

Tracking

2.19
Bugzilla 2.20
Bug Flags:
blocking2.20 -

Details

(Reporter)

Description

14 years ago
Simple boolean checking of get_index_def's return value is error-prone, since
multi-column indexes are listed one column at a time, so an index on columns
(foo, bar) of table "baz" will cause get_index_def("baz","bar") to return a true
value even though that index may not satisfy the need for which get_index_def
was called, since if you are searching just "bar" instead of both columns you
won't be able to use that multi-column index.
Flags: blocking2.20+
Target Milestone: --- → Bugzilla 2.20
(Assignee)

Comment 1

14 years ago
Oh, definitely known. All the old schema-checking functions have logical errors
in them, pretty much.

They are all going away as part of bug 285722, and being replaced with much
nicer functions that work sanely. :-)
Depends on: 285722
Whiteboard: [blocker will fix]
(Reporter)

Comment 2

14 years ago
"If it's not a regression from 2.18 and it's not a critical problem with
something that's already landed, let's push it off." - Dave
Flags: blocking2.20+
(Reporter)

Updated

14 years ago
Flags: blocking2.20-

Comment 3

13 years ago
mkanat, is this bug fixed now?
(Assignee)

Comment 4

13 years ago
Yeah. Fixed by blocker.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Whiteboard: [blocker will fix]
Assignee: general → mkanat
You need to log in before you can comment on or make changes to this bug.