Mozilla can't start when creating a new profile at the first time.

RESOLVED FIXED

Status

SeaMonkey
Startup & Profiles
RESOLVED FIXED
13 years ago
8 years ago

People

(Reporter: Boying Lu, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

952 bytes, patch
neil@parkwaycc.co.uk
: review+
Details | Diff | Splinter Review
945 bytes, patch
neil@parkwaycc.co.uk
: superreview+
Details | Diff | Splinter Review
946 bytes, patch
Details | Diff | Splinter Review
946 bytes, patch
Conrad Carlen (not reading bugmail)
: review+
neil@parkwaycc.co.uk
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

13 years ago
Steps to Reproduce:
1. Install Cinnabar31
2. Open a terminal, run "rm -rf .mozilla", "rm -rf .java".
3. Still in the terminal, run "mozilla -P".
4. In Create Profile Wizard dialog, click Next.
5. Click Finish to create a new profile by the default name.

Bug Observation:
Mozilla can't start this time and error message in the terminal: 
"Application Finalize Called"
When you start Mozilla again, it can start up.
(Reporter)

Comment 1

13 years ago
Created attachment 178918 [details] [diff] [review]
patch
Attachment #178918 - Flags: review?(neil.parkwaycc.co.uk)

Comment 2

13 years ago
Why are you starting Mozilla with just -P ?

Comment 3

13 years ago
Comment on attachment 178918 [details] [diff] [review]
patch

I wonder if we should do anything in the Cancel case...

>+    dialogParams.SetInt(0,1); //since this is the only one profile avaiable, use it
Nit: space after comma please. Also that comment is inaccurate, as this code is
also used by the -ProfileWizard function.
Attachment #178918 - Flags: review?(neil.parkwaycc.co.uk) → review+
(Reporter)

Updated

13 years ago
Attachment #178918 - Flags: superreview?(brendan)
(Reporter)

Comment 4

13 years ago
Created attachment 179154 [details] [diff] [review]
revised
Attachment #179154 - Flags: superreview?(neil.parkwaycc.co.uk)
Attachment #179154 - Flags: review?(ccarlen)

Comment 5

13 years ago
Comment on attachment 179154 [details] [diff] [review]
revised 

>+    dialogParams.SetInt(0, 1); //set the newly created profile as the defult
Nit: typo: "default"
Attachment #179154 - Flags: superreview?(neil.parkwaycc.co.uk) → superreview+
(Reporter)

Comment 6

13 years ago
Created attachment 179159 [details] [diff] [review]
another one

Sorry, for the mistake
Attachment #179159 - Flags: superreview?(neil.parkwaycc.co.uk)
Attachment #179159 - Flags: review?(ccarlen)
(Reporter)

Comment 7

13 years ago
Created attachment 179160 [details] [diff] [review]
another one

Sorry for the mistake
Attachment #179160 - Flags: superreview?(neil.parkwaycc.co.uk)
Attachment #179160 - Flags: review?(ccarlen)

Updated

13 years ago
Attachment #179160 - Flags: superreview?(neil.parkwaycc.co.uk) → superreview+

Updated

13 years ago
Summary: Mozilla can't start when creat a new profile at the first time. → Mozilla can't start when creating a new profile at the first time.
Comment on attachment 179160 [details] [diff] [review]
another one

Does this bug mean that the -ProfileWizard switch is broken as well? Looks like
it would hit this as well. Starting with no profile, -P without a value, and
having the CreateProfile wizard come up is wrong. I see why it's happening but,
really -P should require a profile name. The command line handler returns "1"
for params with no value and that's why we end up bringing up the profile
wizard.

If the -ProfileWizard switch is broken and this fixes it, r=ccarlen. The
'Cancel' case should work because nsDialogParamBlock inits all values to 0, but
I'd rather see it done explicitly in the code you added.
Attachment #179160 - Flags: review?(ccarlen) → review+
(Reporter)

Comment 9

13 years ago
Thanks. Can we check in th patch now?

Comment 10

13 years ago
Done, leaving the bug open in case someone wants to resolve comment 8.

Comment 11

13 years ago
Comment on attachment 179159 [details] [diff] [review]
another one

Removing obsolete requests...
Attachment #179159 - Flags: superreview?(neil.parkwaycc.co.uk)
Attachment #179159 - Flags: review?(ccarlen)

Updated

11 years ago
Attachment #178918 - Flags: superreview?(brendan)

Updated

9 years ago
Attachment #179154 - Flags: review?(ccarlen)

Comment 12

9 years ago
Comment on attachment 179154 [details] [diff] [review]
revised 

> Removing obsolete requests...
You missed one.

Comment 13

8 years ago
(In reply to comment #10)
> Done, leaving the bug open in case someone wants to resolve comment 8.

Actually, please, let's close a bug that has almost all this work done - and if that other problem still is there, please file a new bug to track that other thing individually.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.