Crashes while attempting to view complete mail header after emptying trash

RESOLVED DUPLICATE of bug 288172

Status

--
critical
RESOLVED DUPLICATE of bug 288172
14 years ago
14 years ago

People

(Reporter: harishn, Assigned: mscott)

Tracking

({crash})

x86
Windows 2000
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2
Build Identifier: Mozilla Thunderbird 1.0.2 (20050317)

I chanced upon this problem doing something stupid.

(Assume you start with View->Headers->Normal) After deleting a few mails,
emptying the trash via Alt-F-Y leaves the last deleted mail still shown in the
mail pane. Attempting to then change the headers preferences to 'all' results in
Thunderbird crashing. The same problem occurs while using both IMAP or POP mail
accounts.

Reproducible: Always

Steps to Reproduce:
1. Delete a bunch of mails, sending them to the trash folder.
2. Click on one of them (in the trash folder) opening the mail in the mail
display pane.
3. Empty the trash for that mail box using alt-f-y. This empties the trash, but
leaves the last e-mail still shown in the mail display pane.
4. Assuming you weren't showing full e-mail headers before, change the setting
to now (attempt to) show full e-mail headers.
Actual Results:  
Thunderbird crashes.

Expected Results:  
The last mail shouldn't be shown once the trash is cleared. Later changing the
preferences to view complete headers should have no effect, until a new mail is
chosen from a different folder.

Comment 1

14 years ago
wfm with trunk build, in the sense that we don't crash...

Comment 2

14 years ago
Harish Narayanan: Could you provide Talkback incident ID for yout crash?
Keywords: crash
Version: unspecified → 1.0

Comment 3

14 years ago
just reproducet it with Version 1.0 (20041206) (de-DE) on Win2000.
Talkback ID: 4691939Q
OS: Windows XP → Windows 2000

Comment 4

14 years ago
NOT reproducable with version 1.0+ (20050321) on winXP.
reporter: please try to reproduce the bug with a recent nightly version of TB
if you can't reproduce it --> WFM
(Reporter)

Comment 5

14 years ago
Adam Hauner: The talkback agent doesn't seem to be catching the crash. I must be
doing something wrong.

Albert Feller: I cannot reproduce it with the nightly (March, 29 2005 trunk)
build. The original error was on a later version than 1.0 (20041206) though. It
was on  1.0.2 (20050317).
(Reporter)

Comment 6

14 years ago
Adam Hauner: Apologies, random stupidity. Again.

The Talkback Incident ID is: TB4694796W

Comment 7

14 years ago
Incident ID: 4694796
Stack Signature	nsMsgDBView::GetURIForViewIndex c00a6741
Product ID	Thunderbird10
Build ID	2005031711
Trigger Time	2005-03-29 14:12:49.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	THUNDE~1.EXE + (0044dc78)
URL visited	
User Comments	Generated trying to reproduce bug 288100
Since Last Crash	20 sec
Total Uptime	20 sec
Trigger Reason	Access violation
Source File, Line No.
e:/builds/tinderbox/Tb-Aviary1.0.1/WINNT_5.0_Depend/mozilla/mailnews/base/src/nsMsgDBView.cpp,
line 2023
Stack Trace 	
nsMsgDBView::GetURIForViewIndex 
[e:/builds/tinderbox/Tb-Aviary1.0.1/WINNT_5.0_Depend/mozilla/mailnews/base/src/nsMsgDBView.cpp,
line 2023]
nsMsgDBView::LoadMessageByViewIndexHelper 
[e:/builds/tinderbox/Tb-Aviary1.0.1/WINNT_5.0_Depend/mozilla/mailnews/base/src/nsMsgDBView.cpp,
line 1049]
nsMsgDBView::ReloadMessageHelper 
[e:/builds/tinderbox/Tb-Aviary1.0.1/WINNT_5.0_Depend/mozilla/mailnews/base/src/nsMsgDBView.cpp,
line 979]
XPCWrappedNative::CallMethod 
[e:/builds/tinderbox/Tb-Aviary1.0.1/WINNT_5.0_Depend/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp,
line 2034]
XPC_WN_CallMethod 
[e:/builds/tinderbox/Tb-Aviary1.0.1/WINNT_5.0_Depend/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 1287]
js_Invoke 
[e:/builds/tinderbox/Tb-Aviary1.0.1/WINNT_5.0_Depend/mozilla/js/src/jsinterp.c,
line 949]
js_Interpret 
[e:/builds/tinderbox/Tb-Aviary1.0.1/WINNT_5.0_Depend/mozilla/js/src/jsinterp.c,
line 2993]
js_Invoke 
[e:/builds/tinderbox/Tb-Aviary1.0.1/WINNT_5.0_Depend/mozilla/js/src/jsinterp.c,
line 966]
js_InternalInvoke 
[e:/builds/tinderbox/Tb-Aviary1.0.1/WINNT_5.0_Depend/mozilla/js/src/jsinterp.c,
line 1043]
JS_CallFunctionValue 
[e:/builds/tinderbox/Tb-Aviary1.0.1/WINNT_5.0_Depend/mozilla/js/src/jsapi.c,
line 3698]
nsJSContext::CallEventHandler 
[e:/builds/tinderbox/Tb-Aviary1.0.1/WINNT_5.0_Depend/mozilla/dom/src/base/nsJSEnvironment.cpp,
line 1297]
nsJSEventListener::HandleEvent 
[e:/builds/tinderbox/Tb-Aviary1.0.1/WINNT_5.0_Depend/mozilla/dom/src/events/nsJSEventListener.cpp,
line 184]
nsEventListenerManager::HandleEventSubType 
[e:/builds/tinderbox/Tb-Aviary1.0.1/WINNT_5.0_Depend/mozilla/content/events/src/nsEventListenerManager.cpp,
line 1436]
nsEventListenerManager::HandleEvent 
[e:/builds/tinderbox/Tb-Aviary1.0.1/WINNT_5.0_Depend/mozilla/content/events/src/nsEventListenerManager.cpp,
line 1516]
nsXULElement::HandleDOMEvent 
[e:/builds/tinderbox/Tb-Aviary1.0.1/WINNT_5.0_Depend/mozilla/content/xul/content/src/nsXULElement.cpp,
line 2841]
PresShell::HandleDOMEventWithTarget 
[e:/builds/tinderbox/Tb-Aviary1.0.1/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsPresShell.cpp,
line 6139]
nsMenuFrame::Execute 
[e:/builds/tinderbox/Tb-Aviary1.0.1/WINNT_5.0_Depend/mozilla/layout/xul/base/src/nsMenuFrame.cpp,
line 1671]
nsMenuFrame::HandleEvent 
[e:/builds/tinderbox/Tb-Aviary1.0.1/WINNT_5.0_Depend/mozilla/layout/xul/base/src/nsMenuFrame.cpp,
line 454]
PresShell::HandleEventInternal 
[e:/builds/tinderbox/Tb-Aviary1.0.1/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsPresShell.cpp,
line 6103]
PresShell::HandleEvent 
[e:/builds/tinderbox/Tb-Aviary1.0.1/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsPresShell.cpp,
line 5921]
nsViewManager::HandleEvent 
[e:/builds/tinderbox/Tb-Aviary1.0.1/WINNT_5.0_Depend/mozilla/view/src/nsViewManager.cpp,
line 2326]
nsViewManager::DispatchEvent 
[e:/builds/tinderbox/Tb-Aviary1.0.1/WINNT_5.0_Depend/mozilla/view/src/nsViewManager.cpp,
line 2066]
HandleEvent 
[e:/builds/tinderbox/Tb-Aviary1.0.1/WINNT_5.0_Depend/mozilla/view/src/nsView.cpp,
line 77]
nsWindow::DispatchEvent 
[e:/builds/tinderbox/Tb-Aviary1.0.1/WINNT_5.0_Depend/mozilla/widget/src/windows/nsWindow.cpp,
line 1067]
nsWindow::DispatchMouseEvent 
[e:/builds/tinderbox/Tb-Aviary1.0.1/WINNT_5.0_Depend/mozilla/widget/src/windows/nsWindow.cpp,
line 5261]
ChildWindow::DispatchMouseEvent 
[e:/builds/tinderbox/Tb-Aviary1.0.1/WINNT_5.0_Depend/mozilla/widget/src/windows/nsWindow.cpp,
line 5511]
nsWindow::WindowProc 
[e:/builds/tinderbox/Tb-Aviary1.0.1/WINNT_5.0_Depend/mozilla/widget/src/windows/nsWindow.cpp,
line 1349]
USER32.dll + 0x8709 (0x77d48709)
USER32.dll + 0x87eb (0x77d487eb)
USER32.dll + 0x89a5 (0x77d489a5)
USER32.dll + 0x89e8 (0x77d489e8)
nsAppShell::Run 
[e:/builds/tinderbox/Tb-Aviary1.0.1/WINNT_5.0_Depend/mozilla/widget/src/windows/nsAppShell.cpp,
line 159]
nsAppShellService::Run 
[e:/builds/tinderbox/Tb-Aviary1.0.1/WINNT_5.0_Depend/mozilla/xpfe/appshell/src/nsAppShellService.cpp,
line 495]
main 
[e:/builds/tinderbox/Tb-Aviary1.0.1/WINNT_5.0_Depend/mozilla/mail/app/nsMailApp.cpp,
line 58]
kernel32.dll + 0x16d4f (0x7c816d4f)


*** This bug has been marked as a duplicate of 288172 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.