right-click on <a href="javascript:..."> and the code is executed as if it was left-click

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
14 years ago
12 years ago

People

(Reporter: lists, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

I've been trying to create some bookmarklets, and the best way I can think of to
present them is to do so as links for people to right-click, and bookmark.  The
problem is, that when you right-click, the code is executed as if it was
left-clicked.

Reproducible: Always

Steps to Reproduce:
1. Create something like <a
href="javascript:location.href='http://google.com'">link</a>
2. Right-click on the link, as if you wanted to copy-address or add-bookmark
 

Actual Results:  
the code is executed (in the case of the example, you're taken to google)

Expected Results:  
nothing should happen -- I should get a menu as if I was clicking on any other
normal link.

note that the menu does still come up, and I can bookmark or copy the address,
but in the case of something more complex than a location redirect (which can be
a pain in and of itself), it's somewhat of a serious annoyance.
Assignee: firefox → general
Component: General → DOM
Product: Firefox → Core
QA Contact: general → ian
Version: unspecified → Trunk
Chris, could you attach a page showing the problem to this bug using
https://bugzilla.mozilla.org/attachment.cgi?bugid=288121&action=enter ?  I can't
seem to reproduce this issue....
(Reporter)

Comment 2

14 years ago
http://forevermore.net/bookmarks.php

But since 1.0.2, I've noticed that it's rather intermitent.  Like something I've
browsed to earlier breaks it, but a fresh browser won't have any trouble.

I don't actually use firefox all that much (I like galeon's tab-handling
better), so I'm not particularly diligent about watching for this one.
I can't seem to reproduce this in suite, so either it's Firefox-specific or
something else is going on....
Assignee: general → nobody
Component: DOM → General
Product: Core → Firefox
QA Contact: ian → general
Created attachment 183052 [details]
testcase

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050508
Firefox/1.0+

WFM

and I'm sure I've never seen this since I started with Phoenix 0.4
(Reporter)

Comment 5

14 years ago
It's almost definitely firefox-specific, since I've never seen it in galeon.  I
was just testing some new galeon-style smart bookmarks in my quest to someday
switch to firefox, and I noticed it happening.  Problem is, it seems to be
intermitent in 1.0.2

Comment 6

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716
Firefox/1.0.6

Could not reproduce.  Have you tested this on a more recent version?  Also, it
could be platform-specific.
(Reporter)

Comment 7

13 years ago
*If* it's still a problem, my guess is that something in memory gets corruped
for window objects after much browsing on (possibly) broken pages, causing it to
freak out after awhile.  Closing/reopening a tab/window would then make the
issue go away (also makes it hard to track down).

Anyway, pages that used to have problems regularly are not an issue anymore.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

13 years ago
I just noticed that this is happening again (1.5b2) with the rss feed title
links at http://google.com/ig.  right-click (or middle-click) on any of the
section titles that allow it (custom rss feeds like engadget.com seem easiest to
deal with), and you'll get the right-click menu, but the new page will also load
(since it's javascript to load a new location)
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
can you reproduce this with a new profile ?
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a2pre) Gecko/20070102 Minefield/3.0a2pre

WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.