fieldset's legend element is not rendered as expected when generated in DOM

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: alex, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

In the page at http://www.ulement.com/test/fieldset.html the FIELDSET element is
being dynamically generated with JavaScript into the DOM tree. The browser
should render the contents of the LEGEND element within the borders of the
FIELDSET element; however, it renders it within the contents of the FIELDSET.

Reproducible: Always

Steps to Reproduce:
1. Run the JavaScript script in the http://www.ulement.com/test/fieldset.html page. 

Actual Results:  
LEGEND element is displayed *within* the fieldset, not within the borders, as
expected.

Expected Results:  
Rendered the contents of the LEGEND element within the borders of the FIELDSET.

Comment 1

14 years ago
In 1.0.2 I can replicate the bug.  In nightly build, March 28th 05 it works as
expected.

Comment 2

14 years ago
WORKSFORME. Please reopen if you can still reproduce this problem in a recent
nightly.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

14 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 3

14 years ago
I don't know how often the nightly changes are integrated into the builds, but
this bug is still present in Firefox 1.0.4 (have been testing since 1.0.2).

Comment 4

14 years ago
You need to test with 1.1, not with 1.0 builds. Nightlies are "integrated" in
the next release, not in the next minor release. Please ask first before
reopening bugs.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → WORKSFORME

Comment 5

14 years ago
Created attachment 183486 [details]
Testcase

Testcase, just to be sure
You need to log in before you can comment on or make changes to this bug.