Hardcoded appname in messenger.properties (filterFolderTruncateFailed)

VERIFIED FIXED

Status

--
minor
VERIFIED FIXED
14 years ago
10 years ago

People

(Reporter: standard8, Assigned: standard8)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Assignee)

Description

14 years ago
The property filterFolderTruncateFailed in messenger.properties hardcodes the
short name of the application: "There was an error truncating the Inbox after
filtering a message to folder '%S'. You may need to shutdown Mozilla and delete
INBOX.msf."

The "Mozilla" should be changed to use brand short name as very soon, we won't
even have any product called "Mozilla" on the trunk any more (see bug 285696).
(Assignee)

Comment 1

14 years ago
Created attachment 178954 [details] [diff] [review]
Patch v1

Patch so that we don't hardcode the appname in messenger.properties - fixes
both Suite & TB.
Attachment #178954 - Flags: review?(neil.parkwaycc.co.uk)

Comment 2

14 years ago
Comment on attachment 178954 [details] [diff] [review]
Patch v1

Seems reasonable, though I've got no idea how to test it.
Attachment #178954 - Flags: review?(neil.parkwaycc.co.uk) → review+
(Assignee)

Updated

14 years ago
Attachment #178954 - Flags: superreview?(mscott)

Updated

14 years ago
Attachment #178954 - Flags: superreview?(mscott) → superreview+

Comment 3

14 years ago
Patch checked in for Mark, marking FIXED.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

14 years ago
*** Bug 287693 has been marked as a duplicate of this bug. ***
Verified FIXED by code inspection via LXR, where I can verify that
messenger.properties doesn't hard-code the app name anymore, and through the
other changes, which show where it does come from...
Status: RESOLVED → VERIFIED
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.