Installer fails with -215 read only error

RESOLVED WORKSFORME

Status

()

Firefox
Installer
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: John, Unassigned)

Tracking

1.0 Branch
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 07/05)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)
Build Identifier: 

Initially tried to install Firefox 1.0.2 update under Win 98 through update 
button in browser.  Firefox 1.0 and 1.01 update installed previously without 
error. Installation of 1.0.2 did not finish due to error: got message similar 
to bug # 267744. Tried to uninstall any version (starting with 1.0.2).  Still 
would not install.  Removed any "mozilla" reference in registry.  Now NO 
version will install.  I always pick "custom install" due to lack of space on c 
drive.  I browse to select d:/program files, which worked with firefox 1.0.

Reproducible: Always

Steps to Reproduce:
1.Under W98 double click installer (any version)
2.accept all defaults until you get to picking installation type
3.select "d:/program files".  Installation proceeds then ends with windows 
error: "Error occured during Installation - Firefox Browser -215 READ_ONLY"

Comment 1

13 years ago
Created attachment 180903 [details]
screenshot of error

Forgive me. This is all complicated and I don't know if I'm really in the right
place, but I'm tired of looking for the right place.  When I update firefox
with the update button in the top right corner it does fine until the actual
installation begins.  Then I get an error as seen in the attatchment.  I have
had this happen on the past couple of updates also.  I managed to fix it by
removing the mozilla firefox folder, but it's rather annoying to have to move
that folder everytime an update comes out.

Comment 2

13 years ago
I also got this error on a Windows 2000 machine with SP4. I already have Version
1.0 running and was installing V1.0.4
Summary: Installer fails with -215 read only error → Installer fails with -215 read only error

Updated

13 years ago
Assignee: bugs → nobody
QA Contact: bugzilla → installer

Comment 3

12 years ago
I get this bug on a Thinkpad 770Z running Win98.  I had a perfectly good installation of 1.0 on this machine that arbitrarily stopped working a few months ago.  Finally tried reinstalling (with the same variations as others have reported--uninstalling old version, manual install, reboot and retry, etc.) but nothing gets me past this error.  Nothing.  It is a showstopper.  So, ya'll trying to force me to use IE, or what?
*** Bug 341025 has been marked as a duplicate of this bug. ***
Version: unspecified → 1.0 Branch

Comment 5

12 years ago
Un-install did not removed existing windows directories
un-installed mozilla and deleted all references and directories and tried re-install. Now good.

Comment 6

12 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)
> Build Identifier: 
> Initially tried to install Firefox 1.0.2 update under Win 98 through update 
> button in browser.  Firefox 1.0 and 1.01 update installed previously without 
> error. Installation of 1.0.2 did not finish due to error: got message similar 
> to bug # 267744. Tried to uninstall any version (starting with 1.0.2).  Still 
> would not install.  Removed any "mozilla" reference in registry.  Now NO 
> version will install.  I always pick "custom install" due to lack of space on c 
> drive.  I browse to select d:/program files, which worked with firefox 1.0.
> Reproducible: Always
> Steps to Reproduce:
> 1.Under W98 double click installer (any version)
> 2.accept all defaults until you get to picking installation type
> 3.select "d:/program files".  Installation proceeds then ends with windows 
> error: "Error occured during Installation - Firefox Browser -215 READ_ONLY"

I too have this error. I doesn't seem cleaning out the regedit is fixing the prob, and I can't think of what could be doing this. 
I had this recently. It turned out that my hard disk was failing, reporting at least one bad sector.

Running chkdsk showed that various files under C:\Program Files\Mozilla Firefox had become corrupt, they could neither be read nor deleted. I replaced the disk with a new one, copied all the existing files from the old disk and then ran chkdsk /F to remove the corrupt files. After this I was able to install Firefox again.
*** Bug 350724 has been marked as a duplicate of this bug. ***
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 07/05
This works for me using Firefox 2.0.0.6 on Windows XP and Vista. If you can still reproduce this, please comment in this bug and reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.