style:hand does not show hand cursor when no href in anchor tag

RESOLVED DUPLICATE of bug 40298

Status

()

Core
HTML: Parser
RESOLVED DUPLICATE of bug 40298
13 years ago
13 years ago

People

(Reporter: Thomas Taranowski, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

Rendered incorrectly - no hand cursor:
<a OnClick="setMain();"><img src="icons/TitleBarMain.gif" style="cursor:hand"></a>

This line is rendered as expected in IE.

All other styles(e.g. cursor:wait) render correctly


Reproducible: Always

Steps to Reproduce:
1.Create an anchor tag, but do no specify an href, but do specify a style
2.Mouse over the link in browser.  
3.The expected behavior is for the arrow cursor to switch to the pointer cursor.


Actual Results:  
Mouse cursor does NOT change to hand, but stays as arrow cursor.

Expected Results:  
The expected behavior is for the arrow cursor to switch to the pointer cursor

This line is rendered as expected in IE.

All other styles(e.g. cursor:wait) render correctly

Beer is good.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 40298 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.