If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

checksetup.pl errors if not using --skip-grant-tables to start mySQL

VERIFIED DUPLICATE of bug 16454

Status

()

Bugzilla
Bugzilla-General
P3
normal
VERIFIED DUPLICATE of bug 16454
18 years ago
5 years ago

People

(Reporter: justdave, Assigned: justdave)

Tracking

Details

Even with the latest CVS update (when the UNCONFIRMED stuff was added at least) 
I'm still getting an error accessing the database when checksetup.pl is run, 
unless I kill the server and restart it with --skip-grant-tables long enough to 
run the checksetup program.  I did some fiddling and managed to make the error go 
away.  Here's the diff of what I changed to fix it:

Index: checksetup.pl
===================================================================
RCS file: /cvsroot/mozilla/webtools/bugzilla/checksetup.pl,v
retrieving revision 1.25
diff -r1.25 checksetup.pl
460c460,462
<     my @databases = $drh->func($db_host, $db_port, '_ListDBs');
---
>     my $dsn = "DBI:$db_base:$db_name;$db_host;$db_port";
>     my $dbh = DBI->connect($dsn, $db_user, $db_pass);
>     my @databases = $dbh->func('_ListDBs');
462,463c464,465
<     print "Creating database $db_name ...\n";
<     $drh->func('createdb', $db_name, 'admin')
---
>        print "Creating database $db_name ...\n";
>        $drh->func('createdb', $db_name, "$db_host:$db_port", $db_user, $db_pass, 'admin')
475a478
>     $dbh->disconnect if $dbh;

Comment 1

18 years ago
tara@tequilarista.org is the new owner of Bugzilla and Bonsai.  (For details,
see my posting in netscape.public.mozilla.webtools,
news://news.mozilla.org/38F5D90D.F40E8C1A%40geocast.com .)
Assignee: terry → tara

Comment 2

18 years ago
This is a duplicate of bug #16454, which was posted on 1-14-99 and Holger 
submitted a patch for on 1-17-00.

Any chance one of these two could get checked into the tree?


*** This bug has been marked as a duplicate of 16454 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
moving to Bugzilla product
reassign to default owner/qa for INVALID/WONTFIX/WORKSFORME/DUPLICATE
Assignee: tara → justdave
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
QA Contact: matty
Version: other → unspecified
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.