mail deleted from server when local copies are moved into folders within inbox

RESOLVED DUPLICATE of bug 226839

Status

Thunderbird
Account Manager
RESOLVED DUPLICATE of bug 226839
13 years ago
12 years ago

People

(Reporter: N Cole, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-GB; rv:1.7.6) Gecko/20050321 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-GB; rv:1.7.6) Gecko/20050321 Firefox/1.0.2

When the "leave mail on server... until I delete or move them from the Inbox"
checkbox is selected under Account settings, mail is deleted from the server
when messages are moved to subfolders of the Inbox. This means, mail can't be
organised   into folders within the Inbox and still remain on the server.

Reproducible: Always

Steps to Reproduce:
1. Tick appropriate check boxes
2. Send email to self from a webmail account
3. Move received mail into a folder within Inbox
4. See if mail if still on server

Actual Results:  
Mail message was deleted.

Expected Results:  
Mail message should have been left on the server.

Comment 1

13 years ago
reproducable: didn't try

reporter, I don't know if this is actually a bug. the inbox is for your incoming
messages, if you want to sort you mail into folders, put the folder not as a
subfolder of the inbox but somewhere else.

i suggest: WONTFIX

Comment 2

13 years ago
Hi!

I think it is not good in this way. If the user has an account somewhere and
want to read his letters from workplace & home too, than he has choices:
1. Leave everything on server. Not good.
2. Every mail will be readable at home or workplace, not both. Not good.
3. Doesn't use any subfolders and leaves every mail in the inbox. Not good enough.

I think it is weird.
Maybe there should be two separate option. One for delete when I delete, another
for delete when I move.

Cheers,
Tomyellow
(Reporter)

Comment 3

13 years ago
(In reply to comment #1)
Hi

I think you misunderstood my comment. The point is that I want to be able to 
sort messages into local folders (whether or not these folders are within the 
inbox or not is irrelevant) whilst keeping a copy on the server. I agree with 
Tomyellow that there should be an option "delete from server when I delete 
locally" and, perhaps, a "delete from server when I move" option.

Thanks

Nick

Comment 4

13 years ago
I realized just now, that OS & hardware are set to MacOS & Macintosh. It should
be all & all.

Cheers,
Tomyellow

Comment 5

13 years ago
I realized just now, that OS & hardware are set to MacOS & Macintosh. It should
be all & all.

Cheers,
Tomyellow

Comment 6

13 years ago
I would call it a bug - in the Mozilla Suite there are no problems with
subfolders in the Inbox, mails still left on the server (under Win XP tested).

Comment 7

13 years ago
afaik, we don't treat sub-folders of the inbox specially, and that's true for
both the suite and thunderbird. So I'd say this is by design.

Comment 8

13 years ago
(In reply to comment #5)
> I realized just now, that OS & hardware are set to MacOS & Macintosh. It should
> be all & all.

NO, on Win XP everything seems fine - mails still left on the server! 

Comment 9

12 years ago
Yes, the double option (isn't such a double option a bit, well, stupid?) should be split into:

Leave on Server:
[ ] until i delete it
[ ] until i move it

outlook express is much better for reading mail at work and at home for this reason. i use thunderbird but have to download all the junk i deleted at work because i can't delete mail from the server just because i moved it to a sub folder...

Comment 10

12 years ago

*** This bug has been marked as a duplicate of 226839 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.